aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Mouring <brad.mouring@ni.com>2016-04-11 00:29:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 22:01:53 +0100
commit47cb52741c946b6bbe09d5ee9a9f2fe855e8d5fb (patch)
tree817e23ba2070b84e79288cdb91babb21b54940ea
parenta68ff298c8466adbce5f81b4f8104dfdc226eaf7 (diff)
downloadopenembedded-core-contrib-47cb52741c946b6bbe09d5ee9a9f2fe855e8d5fb.tar.gz
busybox-1.23: Backport patch to fix zcip false-conflict
Busybox upstream fixed the issue where an incorrect comparison of addresses led to bogus renegotiation of a new ll ip in 1.24. Backport this change to 1.23.2. Signed-off-by: Brad Mouring <brad.mouring@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch38
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.2.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch b/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch
new file mode 100644
index 0000000000..dec5eb5cf1
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch
@@ -0,0 +1,38 @@
+From 4d15068d83054a9f82b3f8842706cd6deb401e25 Mon Sep 17 00:00:00 2001
+From: Vladislav Grishenko <themiron@mail.ru>
+Date: Thu, 19 Mar 2015 16:19:35 +0500
+Subject: [PATCH] zcip: fix wrong comparison of source IP with our IP
+
+Commit "zcip: fix link-local IP conflict detection" has introduced
+wrong comparsion of source IP with our IP. This leads to a new IP
+being picked unnecessarily on every incoming ARP packet.
+
+Signed-off-by: Vladislav Grishenko <themiron@mail.ru>
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+
+This change was picked from Busybox without modification
+(git://git.busybox.net/busybox, commit 4d15068)
+
+Upstream-Status: Backport (added in 1.24)
+Signed-off-by: Brad Mouring <brad.mouring@ni.com>
+
+---
+ networking/zcip.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/networking/zcip.c b/networking/zcip.c
+index a3307c5..962ba2e 100644
+--- a/networking/zcip.c
++++ b/networking/zcip.c
+@@ -521,7 +521,7 @@ int zcip_main(int argc UNUSED_PARAM, char **argv)
+ target_ip_conflict = 0;
+
+ if (memcmp(&p.arp.arp_sha, &eth_addr, ETH_ALEN) != 0) {
+- if (memcmp(p.arp.arp_spa, &ip.s_addr, sizeof(struct in_addr))) {
++ if (memcmp(p.arp.arp_spa, &ip.s_addr, sizeof(struct in_addr)) == 0) {
+ /* A probe or reply with source_ip == chosen ip */
+ source_ip_conflict = 1;
+ }
+--
+2.7.3
+
diff --git a/meta/recipes-core/busybox/busybox_1.23.2.bb b/meta/recipes-core/busybox/busybox_1.23.2.bb
index 7258df022b..5edcbfd8df 100644
--- a/meta/recipes-core/busybox/busybox_1.23.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.23.2.bb
@@ -36,6 +36,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://0001-Use-CC-when-linking-instead-of-LD-and-use-CFLAGS-and.patch \
file://0002-Passthrough-r-to-linker.patch \
file://0001-randconfig-fix.patch \
+ file://0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch \
file://mount-via-label.cfg \
file://sha1sum.cfg \
file://sha256sum.cfg \