aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-02-09 00:36:04 -0800
committerRobert Yang <liezhi.yang@windriver.com>2017-02-20 02:21:12 +0000
commitfa55ec72540126a55b195a99f56e1305b5a77c5d (patch)
tree985b600a9981a8fb1c9b9b54c8fb48153dbebeb5
parent300134d86083827180fdc2a709c8d521c5d93a22 (diff)
downloadopenembedded-core-contrib-fa55ec72540126a55b195a99f56e1305b5a77c5d.tar.gz
tcl: extend to nativesdk
Fixed: $ bitbake nativesdk-expect ERROR: Nothing PROVIDES 'nativesdk-tcl' (but virtual:nativesdk:expect_5.45.bb DEPENDS on or otherwise requires it). Close matches: [snip] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.6.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
index 2dd0a7ae98..c828b38772 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
@@ -54,8 +54,8 @@ do_install() {
autotools_do_install install-private-headers
ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
- sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh
- sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
+ sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tclConfig.sh
+ sed -i "s;${WORKDIR};${STAGING_INCDIR};g" tclConfig.sh
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${libdir}
@@ -78,7 +78,7 @@ RDEPENDS_${PN} += "tcl-lib"
RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN}-ptest += "libgcc"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
do_compile_ptest() {
oe_runmake tcltest