summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2020-05-11 21:28:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-12 15:19:56 +0100
commita2236917395239eba7a8358ca4de61fd0d25b27f (patch)
treeee8ff67f96c8028a1563fa382e9ebb64cd2fd077
parent0bd81166946cea15eab3e6df9a1141d6a7373a20 (diff)
downloadopenembedded-core-contrib-a2236917395239eba7a8358ca4de61fd0d25b27f.tar.gz
file: add PACKAGECONFIG for auto options
A few options of file configure are set to auto, which can lead to unpredictable effects when something in the sysroot does provide things that satisfy the autotools checks. In the worst case this will lead to package-qa failures as libraries are not set in RDEPENDS but configured for the tool. To mitigate changes of accidental configure set explicit options via newly introduced PACKAGECONFIG variables for bzip, lzma and zlib support, where the default is just zlib, as it was before Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/file/file_5.38.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-devtools/file/file_5.38.bb b/meta/recipes-devtools/file/file_5.38.bb
index b8f09107e8..f5ad568936 100644
--- a/meta/recipes-devtools/file/file_5.38.bb
+++ b/meta/recipes-devtools/file/file_5.38.bb
@@ -8,8 +8,8 @@ SECTION = "console/utils"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
-DEPENDS = "zlib file-replacement-native"
-DEPENDS_class-native = "zlib-native"
+DEPENDS = "file-replacement-native"
+DEPENDS_class-native = ""
SRC_URI = "git://github.com/file/file.git"
@@ -18,6 +18,12 @@ S = "${WORKDIR}/git"
inherit autotools update-alternatives
+PACKAGECONFIG ??= "zlib"
+PACKAGECONFIG_class-native ??= "zlib"
+PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
+PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
+PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
+
EXTRA_OECONF += "--disable-libseccomp"
ALTERNATIVE_${PN} = "file"