summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-10-08 13:14:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-08 20:52:32 +0100
commit487eb18928c26e7781bb86a972369f3594ecdcca (patch)
tree8e7ff610ea4aa3a5f02389264c0d99c1c0c1026f
parent34834d06ceb84221dd53defd27eb94201723d6c5 (diff)
downloadopenembedded-core-contrib-487eb18928c26e7781bb86a972369f3594ecdcca.tar.gz
llvm: remove -mlongcall from CXXFLAGS for powerpc
after gcc upgrade to 9.1.0, with this flags will make below error: collect2: fatal error: ld terminated with signal 11 [Segmentation fault] remove it as workaround, after remove it, powerpc can compile successfully Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 08b19a33e3..9b113f692f 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -86,8 +86,6 @@ EXTRA_OECMAKE_append_class-nativesdk = "\
-DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
"
-CXXFLAGS_append_class-target_powerpc = " -mlongcall"
-
do_configure_prepend() {
# Fix paths in llvm-config
sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp