summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-09-23 11:52:38 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-27 13:01:17 +0100
commit7ed7dc39e379c18f757e3c326ec1466c8ab27b41 (patch)
tree87e4755a0260c55c5d907001ea7075f9c4594b35
parent4433d3133ce53cdf7db17f5e7914fe8c4d78dba3 (diff)
downloadopenembedded-core-contrib-7ed7dc39e379c18f757e3c326ec1466c8ab27b41.tar.gz
python3-subunit: ensure runtime dependencies are present
Without access to unittest, subunit cannot be imported in python3: root@qemux86-64:~# python3 Python 3.7.4 (default, Sep 20 2019, 13:38:31) [GCC 9.2.0] on linux Type "help", "copyright", "credits" or "license" for more information. >>> import subunit Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib/python3.7/site-packages/subunit/__init__.py", line 123, in <module> import unittest ModuleNotFoundError: No module named 'unittest' >>> Adding python3-testtools to python3-subunit's RDEPENDS fixes the issue. This also implicitly provides the functionality found in the python3-extras module. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-subunit_1.3.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-subunit_1.3.0.bb b/meta/recipes-devtools/python/python3-subunit_1.3.0.bb
index 2ece4451df..55066e2d0f 100644
--- a/meta/recipes-devtools/python/python3-subunit_1.3.0.bb
+++ b/meta/recipes-devtools/python/python3-subunit_1.3.0.bb
@@ -1,2 +1,4 @@
inherit setuptools3
require python-subunit.inc
+
+RDEPENDS_${PN} = " python3-testtools"