aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-27 17:20:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-06 10:30:58 +0100
commita4b5076b2c06cafff0ce764955d0aa7c334c7a8e (patch)
tree7f4f3cc0049aeec7179cf953b3c08f1b14729767
parent061c53c86e483c65f5cd350d6587dbae53c4ee75 (diff)
downloadopenembedded-core-contrib-a4b5076b2c06cafff0ce764955d0aa7c334c7a8e.tar.gz
dbus-test: install executables not libtool wrapper scripts
All of the binaries are linked with libtool now, so install the binaries and not the wrapper scripts. Also remove dbus-1.init from SRC_URI as dbus-test doesn't use it. [ YOCTO #9528 ] Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.10.6.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.10.6.bb b/meta/recipes-core/dbus/dbus-test_1.10.6.bb
index a768a09c4a..3748fe6df4 100644
--- a/meta/recipes-core/dbus/dbus-test_1.10.6.bb
+++ b/meta/recipes-core/dbus/dbus-test_1.10.6.bb
@@ -12,7 +12,6 @@ RDEPENDS_${PN}-dev = ""
SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://tmpdir.patch \
- file://dbus-1.init \
file://run-ptest \
file://python-config.patch \
file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
@@ -49,13 +48,11 @@ do_install() {
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
- case1="shell printf refs syslog"
- for i in ${case1}; do install ${B}/test/test-$i ${D}${PTEST_PATH}/test; done
- case2="marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay"
- for i in ${case2}; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
- case3="bus bus-system bus-launch-helper"
- for i in ${case3}; do install ${B}/bus/test-$i ${D}${PTEST_PATH}/test; done
- install ${B}/dbus/test-dbus ${D}${PTEST_PATH}/test
+ l="shell printf refs syslog marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay"
+ for i in $l; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
+ l="bus bus-system bus-launch-helper"
+ for i in $l; do install ${B}/bus/.libs/test-$i ${D}${PTEST_PATH}/test; done
+ install ${B}/dbus/.libs/test-dbus ${D}${PTEST_PATH}/test
cp -r ${B}/test/data ${D}${PTEST_PATH}/test
}
RDEPENDS_${PN}-ptest += "bash"