summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-27 11:07:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-28 14:16:26 +0100
commit9c0cc06a3d857124c0e1c1c9342f79ba5a3b10bc (patch)
tree51cd666716b86d85206d62f83e2a4fd82953cccc
parent33cd0f7e23d714869eda249ae6c3f9761caa4c96 (diff)
downloadopenembedded-core-contrib-9c0cc06a3d857124c0e1c1c9342f79ba5a3b10bc.tar.gz
python3-pygobject: do not supply unknown g-i options
meson 0.60 turns unknown options into them hard errors, so instead of relying on g-i class (where the options are mandatory) add g-i dependencies explicitly. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.42.0.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.42.0.bb b/meta/recipes-devtools/python/python3-pygobject_3.42.0.bb
index 461ddcfe31..7ff7c5b4dd 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.42.0.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.42.0.bb
@@ -6,10 +6,19 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even
+inherit gnomebase distutils3-base upstream-version-is-even
DEPENDS += "python3 glib-2.0"
+# Generating introspection data depends on a combination of native and target
+# introspection tools, and qemu to run the target tools.
+DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native"
+
+# Even though introspection is disabled on -native, gobject-introspection package is still
+# needed for m4 macros.
+DEPENDS:append:class-native = " gobject-introspection-native"
+DEPENDS:append:class-nativesdk = " gobject-introspection-native"
+
SRCNAME="pygobject"
SRC_URI = " \
@@ -18,8 +27,6 @@ SRC_URI = " \
"
SRC_URI[sha256sum] = "9b12616e32cfc792f9dc841d9c472a41a35b85ba67d3a6eb427e307a6fe4367b"
-UNKNOWN_CONFIGURE_WHITELIST = "introspection"
-
S = "${WORKDIR}/${SRCNAME}-${PV}"
PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"