summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-02 23:21:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-03 22:35:19 +0000
commit222574d744b6605ad938e1b7c64834303bcbea92 (patch)
tree33e5699b948efaedf403ed1ff89f7de9968ae22c
parentb4c7b1ea43834fff618e8321537cd224c72a7055 (diff)
downloadopenembedded-core-contrib-222574d744b6605ad938e1b7c64834303bcbea92.tar.gz
musl: Upgrade beyond 1.24
License-Change: Added ARM to copyright files [1] [2] [3] Detailed changes are here [4] [1] https://git.musl-libc.org/cgit/musl/commit/COPYRIGHT?id=db3cc9a319c788cf5241ea68d3fa86b43f35733e [2] https://git.musl-libc.org/cgit/musl/commit/?id=daa29e894c74d61296fe19d9b7c4be2f04037639 [3] https://git.musl-libc.org/cgit/musl/commit/?id=d3f7df235904439d48db041c7796e5b44be5b8e6 [4] https://git.musl-libc.org/cgit/musl/log/?qt=range&q=2c2477da9a553c0b9b2fa18073a5dcdbe6d395af..70d80609558153a996833392999c69cdb74e1119 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/musl/musl.inc2
-rw-r--r--meta/recipes-core/musl/musl/0001-riscv-Define-sigcontext-again.patch48
-rw-r--r--meta/recipes-core/musl/musl_git.bb5
3 files changed, 3 insertions, 52 deletions
diff --git a/meta/recipes-core/musl/musl.inc b/meta/recipes-core/musl/musl.inc
index 0683bf85ed..9aea2c39c8 100644
--- a/meta/recipes-core/musl/musl.inc
+++ b/meta/recipes-core/musl/musl.inc
@@ -9,7 +9,7 @@ standards-conformance and safety."
HOMEPAGE = "http://www.musl-libc.org/"
LICENSE = "MIT"
SECTION = "libs"
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d0fe2be17bc45ff4a42ade1c13ed6340"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f95ee848a08ad253c04723da00cedb01"
INHIBIT_DEFAULT_DEPS = "1"
diff --git a/meta/recipes-core/musl/musl/0001-riscv-Define-sigcontext-again.patch b/meta/recipes-core/musl/musl/0001-riscv-Define-sigcontext-again.patch
deleted file mode 100644
index fcb324e15f..0000000000
--- a/meta/recipes-core/musl/musl/0001-riscv-Define-sigcontext-again.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-commit a0993f8f0f161423ecdcb754f282ffd2fe47a7b5
-Author: Rich Felker <dalias@aerifal.cx>
-Date: Wed Oct 2 09:28:03 2019 -0400
-
- reintroduce riscv64 struct sigcontext
-
- commit ab3eb89a8b83353cdaab12ed017a67a7730f90e9 removed it as part of
- correcting the mcontext_t definition, but there is still code using
- struct sigcontext and expecting the member names present in it, most
- notably libgcc_eh. almost all such usage is incorrect, but bring back
- struct sigcontext at least for now so as not to introduce regressions.
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-diff --git a/arch/riscv64/bits/signal.h b/arch/riscv64/bits/signal.h
-index 03fe48c1..2ff4be30 100644
---- a/arch/riscv64/bits/signal.h
-+++ b/arch/riscv64/bits/signal.h
-@@ -6,12 +6,6 @@
- # define SIGSTKSZ 8192
- #endif
-
--#if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
--typedef unsigned long greg_t;
--typedef unsigned long gregset_t[32];
--typedef union __riscv_mc_fp_state fpregset_t;
--#endif
--
- typedef unsigned long __riscv_mc_gp_state[32];
-
- struct __riscv_mc_f_ext_state {
-@@ -41,6 +35,16 @@ typedef struct mcontext_t {
- union __riscv_mc_fp_state __fpregs;
- } mcontext_t;
-
-+#if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-+typedef unsigned long greg_t;
-+typedef unsigned long gregset_t[32];
-+typedef union __riscv_mc_fp_state fpregset_t;
-+struct sigcontext {
-+ gregset_t gregs;
-+ fpregset_t fpregs;
-+};
-+#endif
-+
- struct sigaltstack {
- void *ss_sp;
- int ss_flags;
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index aacff79f7c..92149b5632 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,9 +4,9 @@
require musl.inc
inherit linuxloader
-SRCREV = "2c2477da9a553c0b9b2fa18073a5dcdbe6d395af"
+SRCREV = "70d80609558153a996833392999c69cdb74e1119"
-BASEVER = "1.1.23"
+BASEVER = "1.1.24"
PV = "${BASEVER}+git${SRCPV}"
@@ -15,7 +15,6 @@ PV = "${BASEVER}+git${SRCPV}"
SRC_URI = "git://git.musl-libc.org/musl \
file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
- file://0001-riscv-Define-sigcontext-again.patch \
"
S = "${WORKDIR}/git"