aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-02-07 09:57:58 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-08 10:54:46 +0000
commitd3ee06845e18ecf94770ff0970c2a0d6631ed214 (patch)
tree3f85cdafedee545caf62a031838d7e318a2c3d47
parent788d97b4f8e4452cef1ba6bb3e565e1b52dbb7de (diff)
downloadopenembedded-core-contrib-d3ee06845e18ecf94770ff0970c2a0d6631ed214.tar.gz
libsolv: fix segfault when using SOLVER_DISFAVOR
Opkg --add-ignore-recommends use the flag SOLVER_DISFAVOR. If a package is set to be ignored as a recommendee, but there are not other recommends on the package graph, libsolv segfaults. Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libsolv/libsolv/0001-solver_solve-only-disfavor-recommends-if-there-are-a.patch33
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.3.bb4
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv/0001-solver_solve-only-disfavor-recommends-if-there-are-a.patch b/meta/recipes-extended/libsolv/libsolv/0001-solver_solve-only-disfavor-recommends-if-there-are-a.patch
new file mode 100644
index 0000000000..139613a0ad
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv/0001-solver_solve-only-disfavor-recommends-if-there-are-a.patch
@@ -0,0 +1,33 @@
+From 19d7cc87adba92d31d5fafdf7db00920d24a96a6 Mon Sep 17 00:00:00 2001
+From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+Date: Wed, 6 Feb 2019 13:24:04 -0600
+Subject: [PATCH] solver_solve: only disfavor recommends if there are any
+
+In a repo that have pkg 'a' and 'b' available, and 'b' is disfavored,
+but 'a' doesn't recommend 'b', libsolv segfaults on
+solver_addrecommendsrules, since solv->recommendsruleq is null. Only
+call solver_addrecommendsrules if there are recommends rules.
+
+Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+
+Upstream-Status: Accepted
+---
+ src/solver.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/solver.c b/src/solver.c
+index a80090d19..ad78327a8 100644
+--- a/src/solver.c
++++ b/src/solver.c
+@@ -3920,7 +3920,7 @@ solver_solve(Solver *solv, Queue *job)
+ else
+ solv->yumobsrules = solv->yumobsrules_end = solv->nrules;
+
+- if (solv->havedisfavored && solv->strongrecommends)
++ if (solv->havedisfavored && solv->strongrecommends && solv->recommendsruleq)
+ solver_addrecommendsrules(solv);
+ else
+ solv->recommendsrules = solv->recommendsrules_end = solv->nrules;
+--
+2.20.1
+
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.3.bb b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
index 44757ac54f..3fe6f2c20a 100644
--- a/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
DEPENDS = "expat zlib"
-SRC_URI = "git://github.com/openSUSE/libsolv.git"
+SRC_URI = "git://github.com/openSUSE/libsolv.git \
+ file://0001-solver_solve-only-disfavor-recommends-if-there-are-a.patch \
+"
SRCREV = "dc7d0f1c3113f2c8217563166906bef3eb5d1ee1"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"