summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-03-09 20:49:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-10 10:29:23 +0000
commit45a350bf9df8aeeaff1f9ded75307ee60f9897a1 (patch)
tree2e6d8b919cdcbc15d888c60b4ba6158c18d76eca
parent559410af0496465f9fbe5e87849b42859328959e (diff)
downloadopenembedded-core-contrib-45a350bf9df8aeeaff1f9ded75307ee60f9897a1.tar.gz
libdnf: replace a musl fix with a better one
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch31
-rw-r--r--meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-include-the-correct-header-on-musl.patch31
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_0.58.0.bb2
3 files changed, 32 insertions, 32 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch b/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch
new file mode 100644
index 0000000000..f8d256e011
--- /dev/null
+++ b/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch
@@ -0,0 +1,31 @@
+From 8aa5402393fabaf4fff51be3af4868e8dfab6da7 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 9 Mar 2021 19:30:42 +0000
+Subject: [PATCH] libdnf/config.h: avoid the use of non-portable __WORDSIZE
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/libdnf/pull/1159]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ libdnf/config.h | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/libdnf/config.h b/libdnf/config.h
+index 16121f6f..2925923e 100644
+--- a/libdnf/config.h
++++ b/libdnf/config.h
+@@ -18,12 +18,10 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+-#include <bits/wordsize.h>
++#include <limits.h>
+
+-#if __WORDSIZE == 32
+-#include "config-32.h"
+-#elif __WORDSIZE == 64
++#if (ULONG_MAX == 0xffffffffffffffff)
+ #include "config-64.h"
+ #else
+-#error "Unknown word size"
++#include "config-32.h"
+ #endif
diff --git a/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-include-the-correct-header-on-musl.patch b/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-include-the-correct-header-on-musl.patch
deleted file mode 100644
index 734521bb3f..0000000000
--- a/meta/recipes-devtools/libdnf/libdnf/0001-libdnf-config.h-include-the-correct-header-on-musl.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 8cc7ada0161a7af38351d1e70516975402f3c5c5 Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Fri, 26 Feb 2021 18:37:41 +0000
-Subject: [PATCH] libdnf/config.h: include the correct header on musl
-
-Problem reported at https://github.com/rpm-software-management/libdnf/issues/1146,
-but this patch isn't quite the fix.
-
-Upstream-Status: Inappropriate
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- libdnf/config.h | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/libdnf/config.h b/libdnf/config.h
-index 16121f6f..51623ce4 100644
---- a/libdnf/config.h
-+++ b/libdnf/config.h
-@@ -18,7 +18,12 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
- */
-
-+#include <features.h>
-+#ifdef __GLIBC__
- #include <bits/wordsize.h>
-+#else
-+#include <bits/reg.h>
-+#endif
-
- #if __WORDSIZE == 32
- #include "config-32.h"
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.58.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.58.0.bb
index eea410af4c..dbe68d5a15 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.58.0.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.58.0.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
file://0001-Add-WITH_TESTS-option.patch \
file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
file://enable_test_data_dir_set.patch \
- file://0001-libdnf-config.h-include-the-correct-header-on-musl.patch \
+ file://0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch \
"
SRCREV = "85278894f21bc1957dc47a2a09ddacf59bc3cda8"