summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-12-21 17:17:54 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-05 13:48:06 +0000
commitb58d9eaac1b6aa2cb1f5e575680a37f55bebdcf1 (patch)
treeecb89412daec12c0bb218d953efc68331bb99480
parent74c5b98979172c0057883568df453da019abe235 (diff)
downloadopenembedded-core-contrib-b58d9eaac1b6aa2cb1f5e575680a37f55bebdcf1.tar.gz
linux-yocto/5.10: update to v5.10.2
Updating linux-yocto/5.10 to the latest korg -stable release that comprises the following commits: d1988041d19d Linux 5.10.2 dadaf794f207 serial: 8250_omap: Avoid FIFO corruption caused by MDR1 access ff654f1d31d5 ALSA: pcm: oss: Fix potential out-of-bounds shift 07747a44be4f USB: sisusbvga: Make console support depend on BROKEN 2440c1cb2514 USB: UAS: introduce a quirk to set no_write_same d769a22dc01f xhci-pci: Allow host runtime PM as default for Intel Maple Ridge xHCI 3203c4abf505 xhci-pci: Allow host runtime PM as default for Intel Alpine Ridge LP 1bee58e891f2 usb: xhci: Set quirk for XHCI_SG_TRB_CACHE_SIZE_QUIRK 2bd9751e6790 xhci: Give USB2 ports time to enter U3 in bus suspend f1e6ab052c63 ALSA: usb-audio: Fix control 'access overflow' errors from chmap cc3edd81ef03 ALSA: usb-audio: Fix potential out-of-bounds shift d8f0c9ec3638 USB: add RESET_RESUME quirk for Snapscan 1212 5fb2a55ad3e0 USB: dummy-hcd: Fix uninitialized array use in init() d483f5e5ce53 USB: legotower: fix logical error in recent commit 2902e302991a ktest.pl: Fix the logic for truncating the size of the log file for email 4e282a8dff80 ktest.pl: If size of log is too big to email, email error message d3f4117b0275 ptrace: Prevent kernel-infoleak in ptrace_get_syscall_info() Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.10.bb22
3 files changed, 18 insertions, 18 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
index 7ced9daa21..1c54ec1719 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
@@ -11,13 +11,13 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "b0c1a1f057968d659a016b919bd834ff13e26c80"
-SRCREV_meta ?= "1c2727e4bf30f06e6135ef59999b53cf465f6371"
+SRCREV_machine ?= "dca023723e0dbfba1c7e8933ca6d70b17af0eab6"
+SRCREV_meta ?= "6b12385f7d89ccac211c3981420a84394530ce83"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
-LINUX_VERSION ?= "5.10.1"
+LINUX_VERSION ?= "5.10.2"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
index 360273b979..1a1845f470 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -6,7 +6,7 @@ KCONFIG_MODE = "--allnoconfig"
require recipes-kernel/linux/linux-yocto.inc
-LINUX_VERSION ?= "5.10.1"
+LINUX_VERSION ?= "5.10.2"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
@@ -15,9 +15,9 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine_qemuarm ?= "24ca6a279d74e25bd07323bb901614d77e88fa2c"
-SRCREV_machine ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_meta ?= "1c2727e4bf30f06e6135ef59999b53cf465f6371"
+SRCREV_machine_qemuarm ?= "d02c60a7622d7f06805925ae1742dad2b36eaab9"
+SRCREV_machine ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_meta ?= "6b12385f7d89ccac211c3981420a84394530ce83"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.10.bb b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
index 9c0a2dbdad..fdfc32123d 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
@@ -12,16 +12,16 @@ KBRANCH_qemux86 ?= "v5.10/standard/base"
KBRANCH_qemux86-64 ?= "v5.10/standard/base"
KBRANCH_qemumips64 ?= "v5.10/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "6f80f1148c616a91d5384c5184c4baa40913bc72"
-SRCREV_machine_qemuarm64 ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_machine_qemumips ?= "8036bb43e87a6071a7f1c6d8b8a7db9c6b6e6343"
-SRCREV_machine_qemuppc ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_machine_qemuriscv64 ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_machine_qemux86 ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_machine_qemux86-64 ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_machine_qemumips64 ?= "a3de5b3de3e9c21a277818694b44fa03472a8939"
-SRCREV_machine ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
-SRCREV_meta ?= "1c2727e4bf30f06e6135ef59999b53cf465f6371"
+SRCREV_machine_qemuarm ?= "5397e4b8744f2319707fef0b1fed890dcdbb30c8"
+SRCREV_machine_qemuarm64 ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_machine_qemumips ?= "925ed2e122804bb2d3b86622c1309c04d8e13652"
+SRCREV_machine_qemuppc ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_machine_qemuriscv64 ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_machine_qemux86 ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_machine_qemux86-64 ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_machine_qemumips64 ?= "2395091f9593bd8465c37f67fabdee14de1900a5"
+SRCREV_machine ?= "0c61b00f3d64aebc1b8248f50d4855d609030fbf"
+SRCREV_meta ?= "6b12385f7d89ccac211c3981420a84394530ce83"
# remap qemuarm to qemuarma15 for the 5.8 kernel
# KMACHINE_qemuarm ?= "qemuarma15"
@@ -30,7 +30,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-LINUX_VERSION ?= "5.10.1"
+LINUX_VERSION ?= "5.10.2"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
3 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687