aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-30 12:30:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-10 22:41:40 +0000
commit0582396081b638811174f9371feacbbf4593bd1a (patch)
treec35732e58bfe8c1fac48b2bd079afb428470c795
parent3e203660a10e958f284fcc03b40583947b42d385 (diff)
downloadopenembedded-core-contrib-0582396081b638811174f9371feacbbf4593bd1a.tar.gz
openssh: don't do aclocal/acinclude dance
Instead, just stop running aclocal. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.6p1.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_7.6p1.bb b/meta/recipes-connectivity/openssh/openssh_7.6p1.bb
index ebb9a5734d..9d940d4590 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.6p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.6p1.bb
@@ -48,6 +48,8 @@ inherit autotools-brokensep ptest
# LFS support:
CFLAGS += "-D__FILE_OFFSET_BITS=64"
+EXTRA_AUTORECONF += "--exclude=aclocal"
+
# login path is hardcoded in sshd
EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
@@ -73,9 +75,6 @@ do_configure_prepend () {
export LD="${CC}"
install -m 0644 ${WORKDIR}/sshd_config ${B}/
install -m 0644 ${WORKDIR}/ssh_config ${B}/
- if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
- cp aclocal.m4 acinclude.m4
- fi
}
do_compile_ptest() {
@@ -162,4 +161,3 @@ CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
ALTERNATIVE_PRIORITY = "90"
ALTERNATIVE_${PN}-scp = "scp"
ALTERNATIVE_${PN}-ssh = "ssh"
-