summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-01-14 13:23:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-15 16:22:46 +0000
commit40e680de829cf0d394f0c10bb7363604b18a489b (patch)
tree957e39075b29a4b8502c4e2713739c01a76970ff
parent3954dc857df1d2a7e559b4fd357b54f39cf7374a (diff)
downloadopenembedded-core-contrib-40e680de829cf0d394f0c10bb7363604b18a489b.tar.gz
linux-yocto/5.15: fix arm defconfig warnings
Integrating the following commit(s) to linux-yocto/5.15: 02bf23d26bc4 arm64: defconfig: cleanup config options 05914e2c87e5 arm: defconfig: drop unused POWER_AVS option Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.15.bb20
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
index f114e0ad4e..0a905d0bff 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "4cf3777087098d1900d7b10f9fa902374e147243"
+SRCREV_machine ?= "04a95b0307715d513560636c2bef4238dde56c86"
SRCREV_meta ?= "9855687d0262b744ef201fc6e019c659033b83b2"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index 1c41406f52..bee98d87cf 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -15,8 +15,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine:qemuarm ?= "d6eeaf39f3beb483733ff2970c901a94093d0b7d"
-SRCREV_machine ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
+SRCREV_machine:qemuarm ?= "149aa4e4f2f3c704e11fd379be32746ab2d3433f"
+SRCREV_machine ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
SRCREV_meta ?= "9855687d0262b744ef201fc6e019c659033b83b2"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
index b6f2fc3b4f..2e093357cb 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
@@ -13,16 +13,16 @@ KBRANCH:qemux86 ?= "v5.15/standard/base"
KBRANCH:qemux86-64 ?= "v5.15/standard/base"
KBRANCH:qemumips64 ?= "v5.15/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "aa48e73490dacca52a99928456050476765b56a7"
-SRCREV_machine:qemuarm64 ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemumips ?= "b15f476dfd5edc44300279429b7de25ec899c2a6"
-SRCREV_machine:qemuppc ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemuriscv64 ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemuriscv32 ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemux86 ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemux86-64 ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
-SRCREV_machine:qemumips64 ?= "e146f932b0ae0c3f764745df1c80aafa0136f276"
-SRCREV_machine ?= "b5879e67153e83a5884bbfa32346dc33d96921e7"
+SRCREV_machine:qemuarm ?= "49cda4a3872929491dbcc3793afbd01709555315"
+SRCREV_machine:qemuarm64 ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemumips ?= "049f989b96848df48c445c2b83c634cc5d692032"
+SRCREV_machine:qemuppc ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemuriscv64 ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemuriscv32 ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemux86 ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemux86-64 ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
+SRCREV_machine:qemumips64 ?= "27a47d7d5d6e7bbe8267f32f8089e395e0eaa863"
+SRCREV_machine ?= "02bf23d26bc4c2e6859aa3810df8d6b955488a06"
SRCREV_meta ?= "9855687d0262b744ef201fc6e019c659033b83b2"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll