aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Randle <william.c.randle@intel.com>2016-03-30 22:11:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-31 23:02:18 +0100
commitc0e0d061d94a1ed2930cbf9a9445cf8cb9f4f9b3 (patch)
treef39f70f7559f4c83c62aa00649eb3a94a7601611
parent4bbd512c4eef6c449d99dbe35271dafc6e7bfe03 (diff)
downloadopenembedded-core-contrib-c0e0d061d94a1ed2930cbf9a9445cf8cb9f4f9b3.tar.gz
man: use BUILD_CC and target include files for configure
The configure script was using the cross-compiler for feature tests, which fails to execute when the target is different than the host. Change the script to use the build compiler instead, but use the target include files to check for the target features. [YOCTO #9359] Signed-off-by: Bill Randle <william.c.randle@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/man/man/man-1.6g-configure.patch68
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb1
2 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man/man-1.6g-configure.patch b/meta/recipes-extended/man/man/man-1.6g-configure.patch
new file mode 100644
index 0000000000..106cc98781
--- /dev/null
+++ b/meta/recipes-extended/man/man/man-1.6g-configure.patch
@@ -0,0 +1,68 @@
+Use BUILD_CC and target include files for configuration tests.
+If cross-compiling, force pathnames for helper programs, since
+autodiscovery by the configure script will not work.
+
+Upstream-Status: Pending
+
+Signed-off-by: Bill Randle <william.c.randle at intel.com>
+
+--- man-1.6g/configure.orig 2016-03-28 17:46:12.734910976 -0700
++++ man-1.6g/configure 2016-03-30 21:47:45.110572908 -0700
+@@ -216,7 +216,8 @@
+ INCLUDEDIR=${INCLUDEDIR-/usr/include}
+
+ rm -f conftest conftest.c
+-compile="$CC $DEFS conftest.c -o conftest $LIBS >/dev/null 2>&1"
++# since we are interested in target feature support, use that sysroot
++compile="$BUILD_CC -isystem/${PKG_CONFIG_SYSROOT_DIR}/usr/include $DEFS conftest.c -o conftest $LIBS >/dev/null 2>&1"
+
+ # Check for various header files.
+
+@@ -455,19 +456,23 @@
+ fi
+ done
+ done
+- Fgroff=/usr/bin/groff
+- Fnroff=/usr/bin/nroff
+- Fjnroff=/usr/bin/nroff
+- Fgeqn=/usr/bin/geqn
+- Fgtbl=/usr/bin/gtbl
+- Fcol=/usr/bin/col
+- Fgrefer=/usr/bin/grefer
+- Fgpic=/usr/bin/gpic
+- Fmore=/bin/more
+- Fless=/usr/bin/less
+- Fcmp=/usr/bin/cmp
+- Fcat=/bin/cat
+- Fgawk=/bin/gawk
++ if [ $BUILD_CC != $CC ]; then
++ # cross compiling => target fs not available, so force defaults
++ Fgroff=/usr/bin/groff
++ Fnroff=/usr/bin/nroff
++ Fjnroff=/usr/bin/nroff
++ Fgeqn=/usr/bin/eqn
++ Fgneqn=/usr/bin/neqn
++ Fgtbl=/usr/bin/tbl
++ Fcol=/usr/bin/col
++ Fgrefer=/usr/bin/refer
++ Fgpic=/usr/bin/pic
++ Fmore=/bin/more
++ Fless=/usr/bin/less
++ Fcmp=/usr/bin/cmp
++ Fcat=/bin/cat
++ Fgawk=/usr/bin/gawk
++ fi
+
+
+ for i in eqn tbl refer pic
+@@ -507,8 +512,8 @@
+ jnroff="$Fjnroff -Tutf8 -mandocj"
+ fi
+ eqn="$Fgeqn -Tps"
+- neqn="$Fgeqn -Tutf8"
+- jneqn="$Fgeqn -Tutf8"
++ neqn="$Fgneqn -Tutf8"
++ jneqn="$Fgneqn -Tutf8"
+ tbl="$Fgtbl"
+ col="$Fcol"
+ vgrind="$Fvgrind"
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
index efdf56569a..e78aa18cbc 100644
--- a/meta/recipes-extended/man/man_1.6g.bb
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -54,6 +54,7 @@ SRC_URI = "http://pkgs.fedoraproject.org/lookaside/pkgs/man2html/${BP}.tar.gz/ba
file://configure_sed.patch \
file://man-1.6g-parallel.patch \
file://man-1.6g-compile-warnings.patch \
+ file://man-1.6g-configure.patch \
"
SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"