aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-08-23 13:16:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-24 09:37:02 +0100
commit6b799e4b315ee5a1eaba9f445b2ba7d37d1e0176 (patch)
treec4fabbff57ac889596d32ad9a122af296f085c6c
parent0a181e26d09978bff850bc6b303de6053f7c53df (diff)
downloadopenembedded-core-contrib-6b799e4b315ee5a1eaba9f445b2ba7d37d1e0176.tar.gz
acl_2.25: improve reproducibility
Remove all host build references from the acl-ptest package. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/attr/acl_2.2.52.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/attr/acl_2.2.52.bb b/meta/recipes-support/attr/acl_2.2.52.bb
index 306c7b5cda..8f3dc45cf7 100644
--- a/meta/recipes-support/attr/acl_2.2.52.bb
+++ b/meta/recipes-support/attr/acl_2.2.52.bb
@@ -43,6 +43,11 @@ do_install_ptest() {
tar -c --exclude=nfs test/ | ( cd ${D}${PTEST_PATH} && tar -xf - )
mkdir ${D}${PTEST_PATH}/include
cp ${S}/include/builddefs ${S}/include/buildmacros ${S}/include/buildrules ${D}${PTEST_PATH}/include/
+ # Remove any build host references
+ sed -e "s:--sysroot=${STAGING_DIR_TARGET}::g" \
+ -e 's:${HOSTTOOLS_DIR}/::g' \
+ -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+ -i ${D}${PTEST_PATH}/include/builddefs
}
RDEPENDS_${PN}-ptest = "acl bash coreutils perl perl-module-filehandle perl-module-getopt-std perl-module-posix shadow"