aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2018-09-24 21:03:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-10 14:33:34 +0100
commitd0d55add6cb01252a46d829ade75666920b676fa (patch)
tree339c2a81441813354cb49e0502b5a506c9aaa6ad
parent51f9a0e58d7b996c4589566963a5853ed93814f7 (diff)
downloadopenembedded-core-contrib-d0d55add6cb01252a46d829ade75666920b676fa.tar.gz
libxml2: Make it compatible with externalsrc
Fetch the test tar ball to a subdirectory in ${S}. This avoids the following error after having done `devtool modify libxml2`: | DEBUG: Executing shell function do_configure | find: ‘.../build/tmp/work/mips32r2el-nf-poky-linux/libxml2/2.9.4-r0/xmlconf/’: No such file or directory Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.8.bb b/meta/recipes-core/libxml/libxml2_2.9.8.bb
index d35f60832a..740bf56a5a 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.8.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.8.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
DEPENDS = "zlib virtual/libiconv"
SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
- http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
+ http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
file://libxml-64bit.patch \
file://runtest.patch \
file://run-ptest \
@@ -77,7 +77,7 @@ FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
do_configure_prepend () {
# executables take longer to package: these should not be executable
- find ${WORKDIR}/xmlconf/ -type f -exec chmod -x {} \+
+ find ${S}/xmlconf/ -type f -exec chmod -x {} \+
}
do_compile_ptest() {
@@ -85,7 +85,7 @@ do_compile_ptest() {
}
do_install_ptest () {
- cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
+ cp -r ${S}/xmlconf ${D}${PTEST_PATH}
if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
${D}${PTEST_PATH}/python/tests/Makefile