aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-02-17 17:14:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 12:29:17 -0800
commit76772f36c4ae8e416b471abe883f117977803aac (patch)
tree548d3cc84ca45d19646ca026890541f9c9106064
parentdd9fdf7a119792b0367f5a1893f6b700f0d3857e (diff)
downloadopenembedded-core-contrib-76772f36c4ae8e416b471abe883f117977803aac.tar.gz
libarchive: fix bzip2 dependency for native build
When DEPENDS=bzip2 becomes bzip2-native in libarchive-native, the dependency ends up getting ignored because bzip2-native is in ASSUME_PROVIDED. But we need the library and thus have to depend on bzip2-replacement-native, otherwise the build proceeds without it despite the explicit --with-bz2lib. (From OE-Core rev: 7ae1c93ab6df46dc88b0ffaa52778738849ff38d) Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.2.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.2.2.bb b/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
index 8ad62adf01..a7c1204bd2 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
@@ -18,11 +18,14 @@ PACKAGECONFIG_append_class-target = "\
PACKAGECONFIG_append_class-nativesdk = " largefile"
+DEPENDS_BZIP2 = "bzip2-replacement-native"
+DEPENDS_BZIP2_class-target = "bzip2"
+
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
-PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2,"
+PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz,"
PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"