aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2017-03-25 01:19:47 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-25 10:56:32 +0000
commit680940250c9a1c7b43229c5e4f4fed5cc3e31033 (patch)
tree8b463883ac3e8c783c078909e9eddaa28aa35ae4
parent552bd782d9ffe275b8fc7d7cb0b9aaceb51888c3 (diff)
downloadopenembedded-core-contrib-680940250c9a1c7b43229c5e4f4fed5cc3e31033.tar.gz
xserver-nodm-init: option to remove cursor
Add a PACKAGECONFIG option to allow the user to disable the mouse cursor/pointer in the X server. This might be useful where a touchscreen is used. Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm.conf.in2
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init_3.0.bb3
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm.conf.in b/meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm.conf.in
index 757c23d95a..4a9670d8d2 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm.conf.in
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm.conf.in
@@ -2,6 +2,6 @@
XSERVER=/usr/bin/Xorg
DISPLAY=:0
-ARGS=" -br -pn @BLANK_ARGS@ "
+ARGS=" -br -pn @BLANK_ARGS@ @NO_CURSOR_ARG@ "
HOME=@HOME@
USER=@USER@
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init_3.0.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init_3.0.bb
index 62da11800c..345b589696 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init_3.0.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init_3.0.bb
@@ -24,6 +24,7 @@ REQUIRED_DISTRO_FEATURES = "x11"
PACKAGECONFIG ??= "blank"
# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
PACKAGECONFIG[blank] = ""
+PACKAGECONFIG[nocursor] = ""
do_install() {
install -d ${D}${sysconfdir}/default
@@ -35,6 +36,7 @@ do_install() {
install X11/Xsession ${D}${sysconfdir}/X11/
BLANK_ARGS="${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}"
+ NO_CURSOR_ARG="${@bb.utils.contains('PACKAGECONFIG', 'nocursor', '-nocursor', '', d)}"
if [ "${ROOTLESS_X}" = "1" ] ; then
XUSER_HOME="/home/xuser"
XUSER="xuser"
@@ -44,6 +46,7 @@ do_install() {
fi
sed -i "s:@HOME@:${XUSER_HOME}:; s:@USER@:${XUSER}:; s:@BLANK_ARGS@:${BLANK_ARGS}:" \
${D}${sysconfdir}/default/xserver-nodm
+ sed -i "s:@NO_CURSOR_ARG@:${NO_CURSOR_ARG}:" ${D}${sysconfdir}/default/xserver-nodm
if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system