aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-08-22 16:36:53 +0800
committerRobert Yang <liezhi.yang@windriver.com>2018-08-23 16:05:42 +0800
commit3b9562e49fad08bde7eff868be27af6d4439cb29 (patch)
treed1949996eb4c5e81e2d882c7532b3d149795838b
parenta0835110df531e0fadc6a769223556057c0e5c6c (diff)
downloadopenembedded-core-contrib-3b9562e49fad08bde7eff868be27af6d4439cb29.tar.gz
psplash: Clean up getstatusoutput usage
Replace usage of oe.utils.getstatusoutput() with direct subprocess calls. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index aab2c0360d..3ad1ef4815 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -73,6 +73,8 @@ ALTERNATIVE_LINK_NAME[psplash] = "${bindir}/psplash"
python do_compile () {
import shutil
+ import subprocess
+ import shlex
# Build a separate executable for each splash image
workdir = d.getVar('WORKDIR')
@@ -82,8 +84,7 @@ python do_compile () {
outputfiles = d.getVar('SPLASH_INSTALL').split()
for localfile, outputfile in zip(localfiles, outputfiles):
if localfile.endswith(".png"):
- outp = oe.utils.getstatusoutput('%s %s POKY' % (convertscript, os.path.join(workdir, localfile)))
- print(outp[1])
+ subprocess.call(shlex.split('%s %s POKY' % (convertscript, os.path.join(workdir, localfile))))
fbase = os.path.splitext(localfile)[0]
shutil.copyfile("%s-img.h" % fbase, destfile)
else: