summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-06-10 14:54:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-11 10:28:12 +0100
commit3464c67cd34acbb1a6705369e34dee8af7e348ac (patch)
tree6f827bddfc7a4eb6adaf4d002a74313302763710
parent6420c8a6a8143f53ccad7ab2d56b2ba06db83099 (diff)
downloadopenembedded-core-contrib-3464c67cd34acbb1a6705369e34dee8af7e348ac.tar.gz
xxhash: fix build with gcc 12
It fails to compile xxhash when '-Og' is set in CFLAGS via such as set DEBUG_BUILD = '1' in local.conf. Check and disable inline when '-Og' exists. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/xxhash/xxhash_0.8.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/xxhash/xxhash_0.8.1.bb b/meta/recipes-support/xxhash/xxhash_0.8.1.bb
index b3b9702598..222ba7b77c 100644
--- a/meta/recipes-support/xxhash/xxhash_0.8.1.bb
+++ b/meta/recipes-support/xxhash/xxhash_0.8.1.bb
@@ -14,6 +14,8 @@ SRCREV = "35b0373c697b5f160d3db26b1cbb45a0d5ba788c"
S = "${WORKDIR}/git"
+CFLAGS += "${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Og', '-DXXH_NO_INLINE_HINTS', '', d)}"
+
do_compile () {
oe_runmake all
}