summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-11-02 19:34:29 -0300
committerSteve Sakoman <steve@sakoman.com>2020-11-09 06:52:34 -1000
commit4afa9f08123df819e53b5d9d586f7a34dcde1ef1 (patch)
tree02a16d303aaff2b6b833e5125b03006b6411e06f
parent4f395ad49ef9035954d0fda7b7df14dea18b49a0 (diff)
downloadopenembedded-core-contrib-4afa9f08123df819e53b5d9d586f7a34dcde1ef1.tar.gz
dosfstools: add mkfs.vfat to ALTERNATIVE
The mkfs.vfat tool can also be provided by busybox via the CONFIG_MKFS_VFAT configuration (not enabled by default in OE but can be enabled on systems avoiding components based on GPLv3). Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1227a29974671fd52014deaca7ac859a037cdeb5) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools_4.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
index 23b8836670..e4ab113391 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
+++ b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b741247
UPSTREAM_CHECK_URI = "https://github.com/dosfstools/dosfstools/releases"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-alternatives
EXTRA_OECONF = "--without-udev --enable-compat-symlinks"
@@ -26,3 +26,7 @@ BBCLASSEXTEND = "native"
# Add codepage437 to avoid error from `dosfsck -l`
RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "mkfs.vfat"
+ALTERNATIVE_LINK_NAME[mkfs.vfat] = "${sbindir}/mkfs.vfat"