summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@windriver.com>2023-01-11 08:20:26 -0800
committerSteve Sakoman <steve@sakoman.com>2023-01-19 13:00:34 -1000
commit6f44b146f0875c588252b5c3b2015a621eba86ab (patch)
tree38b94cec73ac55d82da3b5532f9c1d55fa7586ad
parentad2b7b4d4138ac5f6f74f69d9d6d88a592b14c6f (diff)
downloadopenembedded-core-contrib-6f44b146f0875c588252b5c3b2015a621eba86ab.tar.gz
at: Change when files are copied
The create_spdx code relies on patched code, if files are changed or added during the do_configure phase they will be missed by the create_spdx process. So we need to ensure files modifications/additions happen in the do_patch phase. Signed-off-by: Saul Wold <saul.wold@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 227c46fe48b64de7574f7b6b407b8c13be71b392) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-extended/at/at_3.2.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/at/at_3.2.5.bb b/meta/recipes-extended/at/at_3.2.5.bb
index 87a436173f..c0c876a644 100644
--- a/meta/recipes-extended/at/at_3.2.5.bb
+++ b/meta/recipes-extended/at/at_3.2.5.bb
@@ -52,8 +52,10 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE:${PN} = "atd.service"
-do_configure:prepend() {
- cp -f ${WORKDIR}/posixtm.[ch] ${S}
+do_patch[postfuncs] += "copy_posix_files"
+
+copy_posix_files() {
+ cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
do_install () {