aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-22 10:55:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-28 08:23:57 +0100
commitd2457880e7bb08b9c2f8d60e70b1d59ed84e9da9 (patch)
tree738e463d1c7590d409f86e04245646fda1e89525
parentfe277bf0a61d5d7787dba699ee1ed4d979ba5cff (diff)
downloadopenembedded-core-contrib-d2457880e7bb08b9c2f8d60e70b1d59ed84e9da9.tar.gz
lighthttp: Use pkg-config for pcre dependency
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch33
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch b/meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch
new file mode 100644
index 0000000000..e395f928ce
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd/pkgconfig.patch
@@ -0,0 +1,33 @@
+Use pkg-config for pcre dependency instead of -config script.
+
+Upstream-Status: Pending
+
+RP 2014/5/22
+
+
+Index: lighttpd-1.4.35/configure.ac
+===================================================================
+--- lighttpd-1.4.35.orig/configure.ac 2014-03-06 14:08:00.000000000 +0000
++++ lighttpd-1.4.35/configure.ac 2014-05-13 16:58:30.758471169 +0000
+@@ -309,16 +309,14 @@
+ AC_MSG_RESULT([$WITH_PCRE])
+
+ if test "$WITH_PCRE" != "no"; then
+- AC_PATH_PROG(PCRECONFIG, pcre-config)
+-
+- if test x"$PCRECONFIG" != x; then
+- PCRE_LIB=`$PCRECONFIG --libs`
+- CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
++ PKG_CHECK_MODULES(PCREPKG, [libpcre], [
++ PCRE_LIB=${PCREPKG_LIBS}
++ CPPFLAGS="$CPPFLAGS ${PCREPKG_CFLAGS}"
+ AC_DEFINE([HAVE_LIBPCRE], [1], [libpcre])
+ AC_DEFINE([HAVE_PCRE_H], [1], [pcre.h])
+- else
++ ], [
+ AC_MSG_ERROR([pcre-config not found, install the pcre-devel package or build with --without-pcre])
+- fi
++ ])
+ fi
+
+ AC_SUBST(PCRE_LIB)
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
index bcab7d1931..0acc37d94f 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
@@ -23,6 +23,7 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
file://lighttpd.conf \
file://lighttpd \
file://lighttpd.service \
+ file://pkgconfig.patch \
"
SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"