summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2020-03-30 10:06:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-30 12:34:58 +0100
commitd687794d98f5956a205c049658f2a0f3c5bc0a3f (patch)
tree90d17d8b87f96bdec56f254a0da9a7903cc4637a
parent2544593dc53f9eca964817390577b3b04e87796f (diff)
downloadopenembedded-core-contrib-d687794d98f5956a205c049658f2a0f3c5bc0a3f.tar.gz
Revert "ifupdown: create file interfaces if not exist"
This reverts commit 4e692daf66d2c9d51d418706e20f4527505dc0bd. The patch did not take into consideration of read-only rootfs, causing the following regression. ERROR "The following packages could not be configured offline and rootfs is read-only: ['100-ifupdown']" The original patch was added to resolve problem running `ifup eth1' on a systemd based rootfs. However, when using systemd, we do not use ifup to manage our network interfaces. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/ifupdown/ifupdown_0.8.35.bb7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb b/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
index a8913e6e29..53cb971d33 100644
--- a/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
+++ b/meta/recipes-core/ifupdown/ifupdown_0.8.35.bb
@@ -48,13 +48,6 @@ do_install_ptest () {
cp -r ${S}/tests/linux ${D}${PTEST_PATH}/tests/
}
-pkg_postinst_ontarget_${PN} () {
- if [ ! -f /etc/network/interfaces ]; then
- mkdir -p /etc/network
- touch /etc/network/interfaces
- fi
-}
-
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "ifup ifdown"