summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 15:49:29 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 16:02:43 -0800
commit1deec77168c68eed0b07aae5da98598cced0d452 (patch)
tree57f1c118c4926bac08afed3211c4fa359f6f5d8f
parent6aa81ff75f180b0ea5ac709021d3239b8b2debe7 (diff)
downloadopenembedded-core-contrib-1deec77168c68eed0b07aae5da98598cced0d452.tar.gz
python3-attrs: move from meta-python
Classes Without Boilerplate * Part of the dependency chain for pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-attrs_20.3.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-attrs_20.3.0.bb b/meta/recipes-devtools/python/python3-attrs_20.3.0.bb
new file mode 100644
index 0000000000..55cfda7180
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-attrs_20.3.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Classes Without Boilerplate"
+HOMEPAGE = "http://www.attrs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff"
+
+SRC_URI[sha256sum] = "832aa3cde19744e49938b91fea06d69ecb9e649c93ba974535d08ad92164f700"
+SRC_URI[md5sum] = "4fe38f89297b2b446d83190fce189f29"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
+RDEPENDS_${PN}_class-nativesdk += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
+
+BBCLASSEXTEND = "native nativesdk"