summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-25 09:14:29 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-11-26 21:18:17 -0800
commit16e81962f73a1616d96ca84a7268d66e24b5328d (patch)
treee3e29e539f55b874a158c2c1caaa65a3c3899997
parentc791accc06c37aada53e3282a620833878c785a1 (diff)
downloadopenembedded-core-contrib-16e81962f73a1616d96ca84a7268d66e24b5328d.tar.gz
python*-setuptools: upgrade to 37.0.0; use pypi.bbclass; improvements
* Simplify python- and python3-setuptools with pypi.bbclass * inherit setuptools rather than distutils * Consolidate common settings in python-setuptools.inc - use PYTHON_PN variable to eliminate duplication - python3-setuptools had RDEPENDS on _markupbase - prior commit it added to -core rather than -misc catchall - installer no longer creates setuptools.pth, drop fixes - easy_install script is installed in /usr/bin/, add --script-dir Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-setuptools.inc39
-rw-r--r--meta/recipes-devtools/python/python-setuptools_36.5.0.bb38
-rw-r--r--meta/recipes-devtools/python/python-setuptools_37.0.0.bb9
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.5.0.bb35
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_37.0.0.bb6
5 files changed, 48 insertions, 79 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools.inc b/meta/recipes-devtools/python/python-setuptools.inc
index 1eae0b6174..c42de62bf1 100644
--- a/meta/recipes-devtools/python/python-setuptools.inc
+++ b/meta/recipes-devtools/python/python-setuptools.inc
@@ -5,17 +5,44 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=9a33897f1bca1160d7aad3835152e158"
-SRCNAME = "setuptools"
+PYPI_PACKAGE_EXT = "zip"
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.zip"
+SRC_URI[md5sum] = "f905ca70d2db37b7284c0f6314ab6814"
+SRC_URI[sha256sum] = "0b95db16abf74d435217f17774245fce1ea5a583e5ae8098d98f4ab0145491e3"
-SRC_URI[md5sum] = "704f500dd55f4bd0be905444f3ba892c"
-SRC_URI[sha256sum] = "ce2007c1cea3359870b80657d634253a0765b0c7dc5a988d77ba803fc86f2c64"
+inherit pypi
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
+DEPENDS += "${PYTHON_PN}"
+DEPENDS_class-native += "${PYTHON_PN}-native"
+DEPENDS_class-nativesdk += "nativesdk-${PYTHON_PN}"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR} \
+ --script-dir=${bindir}"
+
+RDEPENDS_${PN}_class-native = "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-compression \
+"
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-compile \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-plistlib \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+"
do_install_prepend() {
install -d ${D}${PYTHON_SITEPACKAGES_DIR}
}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python-setuptools_36.5.0.bb b/meta/recipes-devtools/python/python-setuptools_36.5.0.bb
deleted file mode 100644
index 526474c7ea..0000000000
--- a/meta/recipes-devtools/python/python-setuptools_36.5.0.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-require python-setuptools.inc
-
-PROVIDES = "python-distribute"
-
-DEPENDS += "python"
-DEPENDS_class-native += "python-native"
-
-inherit distutils
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
-
-RDEPENDS_${PN} = "\
- python-stringold \
- python-email \
- python-shell \
- python-distutils \
- python-compression \
- python-pkgutil \
- python-plistlib \
- python-numbers \
- python-html \
- python-netserver \
- python-ctypes \
- python-subprocess \
- python-unittest \
- python-compile \
-"
-
-RDEPENDS_${PN}_class-native = "\
- python-distutils \
- python-compression \
-"
-
-RREPLACES_${PN} = "python-distribute"
-RPROVIDES_${PN} = "python-distribute"
-RCONFLICTS_${PN} = "python-distribute"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python-setuptools_37.0.0.bb b/meta/recipes-devtools/python/python-setuptools_37.0.0.bb
new file mode 100644
index 0000000000..cf9440495b
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_37.0.0.bb
@@ -0,0 +1,9 @@
+require python-setuptools.inc
+
+PROVIDES = "python-distribute"
+
+inherit setuptools
+
+RREPLACES_${PN} = "python-distribute"
+RPROVIDES_${PN} = "python-distribute"
+RCONFLICTS_${PN} = "python-distribute"
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
deleted file mode 100644
index dab8ad89b0..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-require python-setuptools.inc
-
-DEPENDS += "python3"
-DEPENDS_class-native += "python3-native"
-DEPENDS_class-nativesdk += "nativesdk-python3"
-
-inherit distutils3
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
-
-# The installer puts the wrong path in the setuptools.pth file. Correct it.
-do_install_append() {
- rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
- mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
- echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
-}
-
-RDEPENDS_${PN}_class-native = "\
- python3-distutils \
- python3-compression \
-"
-RDEPENDS_${PN} = "\
- python3-ctypes \
- python3-distutils \
- python3-email \
- python3-numbers \
- python3-compression \
- python3-shell \
- python3-pkgutil \
- python3-threading \
- python3-misc \
- python3-unittest \
- python3-xml \
-"
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-setuptools_37.0.0.bb b/meta/recipes-devtools/python/python3-setuptools_37.0.0.bb
new file mode 100644
index 0000000000..0dc1ed8622
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_37.0.0.bb
@@ -0,0 +1,6 @@
+require python-setuptools.inc
+inherit setuptools3
+
+do_install_append() {
+ mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
+}