aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:11:59 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-12-11 21:15:37 -0800
commit04d0b3f089e46f8640c359b2f21d9bf24ab80e4f (patch)
tree269f9d80fa262d43ee84602b4ec58d3bb8c53a76
parenta95b62bd7f435e38f5d3533fcb38b653e3bf9c81 (diff)
downloadopenembedded-core-contrib-04d0b3f089e46f8640c359b2f21d9bf24ab80e4f.tar.gz
python-smmap: use pypi.bbclass
* Simpify python3-smmap using pypi.bbclass * Consolidate common content in .inc Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-smmap.inc12
-rw-r--r--meta/recipes-devtools/python/python3-smmap_0.9.0.bb5
2 files changed, 7 insertions, 10 deletions
diff --git a/meta/recipes-devtools/python/python-smmap.inc b/meta/recipes-devtools/python/python-smmap.inc
index d67e6b5412..32438350c1 100644
--- a/meta/recipes-devtools/python/python-smmap.inc
+++ b/meta/recipes-devtools/python/python-smmap.inc
@@ -7,13 +7,13 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/smmap/smmap-${PV}.tar.gz"
+inherit pypi
+
SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/smmap/"
-UPSTREAM_CHECK_REGEX = "/smmap/(?P<pver>(\d+[\.\-_]*)+)"
-
-S = "${WORKDIR}/smmap-${PV}"
-
+RDEPENDS_${PN} += "${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-lang \
+ ${PYTHON_PN}-mmap \
+"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-smmap_0.9.0.bb b/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
index 9f8a26d79e..e87b8df8c5 100644
--- a/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
+++ b/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
@@ -1,5 +1,2 @@
-require python-smmap.inc
-
inherit setuptools3
-
-RDEPENDS_${PN} += "python3-codecs python3-mmap python3-lang"
+require python-smmap.inc