aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-01-17 16:53:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-18 12:49:22 +0000
commit287446f5c0f3108efc0429bf84be45413970b7a8 (patch)
treea0aa610c50cc63a4154aa5f2992d2fb0edcd4ff0
parentce3dd3c49fd9845ba55c5d1f179b8bf362a42df7 (diff)
downloadopenembedded-core-contrib-287446f5c0f3108efc0429bf84be45413970b7a8.tar.gz
mesa: improve build reproducibility
Sort the output to ensure reproducibility. Fixes [YOCTO #12479] Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/mesa/files/0001-anv_icd.py-improve-reproducible-builds.patch27
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.3.2.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-anv_icd.py-improve-reproducible-builds.patch b/meta/recipes-graphics/mesa/files/0001-anv_icd.py-improve-reproducible-builds.patch
new file mode 100644
index 0000000000..da7a81f253
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0001-anv_icd.py-improve-reproducible-builds.patch
@@ -0,0 +1,27 @@
+From b474abdd91158a52821c34865277d7de38880529 Mon Sep 17 00:00:00 2001
+From: "Maxin B. John" <maxin.john@intel.com>
+Date: Wed, 17 Jan 2018 15:53:29 +0200
+Subject: [PATCH] anv_icd.py: improve reproducible builds
+
+Sort the output to ensure reproducibility
+
+Upstream-Status: Pending
+
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+ src/intel/vulkan/anv_icd.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/intel/vulkan/anv_icd.py b/src/intel/vulkan/anv_icd.py
+index 4ed01fa..31bb068 100644
+--- a/src/intel/vulkan/anv_icd.py
++++ b/src/intel/vulkan/anv_icd.py
+@@ -44,4 +44,4 @@ if __name__ == '__main__':
+ }
+
+ with open(args.out, 'w') as f:
+- json.dump(json_data, f, indent = 4)
++ json.dump(json_data, f, indent = 4, sort_keys=True)
+--
+2.4.0
+
diff --git a/meta/recipes-graphics/mesa/mesa_17.3.2.bb b/meta/recipes-graphics/mesa/mesa_17.3.2.bb
index 9e9b23322a..c2143ad32d 100644
--- a/meta/recipes-graphics/mesa/mesa_17.3.2.bb
+++ b/meta/recipes-graphics/mesa/mesa_17.3.2.bb
@@ -9,6 +9,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://llvm-config-version.patch \
file://0001-winsys-svga-drm-Include-sys-types.h.patch \
file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ file://0001-anv_icd.py-improve-reproducible-builds.patch \
"
SRC_URI[md5sum] = "5c59b779925f504ffd0f13c7dcd29ac6"