aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-05-07 17:05:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-11 12:24:21 +0100
commit510e64d90d3ef2f9757bfa148e8cc09e4834051d (patch)
tree8988a1a048b3149d2996b56cfadc7c2c0aaf03ef
parentaa983d9117d2ddc0906aafdb7a9e584097475275 (diff)
downloadopenembedded-core-contrib-510e64d90d3ef2f9757bfa148e8cc09e4834051d.tar.gz
libxcb: disable check to avoid floating dependencies
The "check" module is checked for in configure without any way to explicitly enable or disable it, but it isn't a build dependency of libxcb. If it's found libxslt is also checked for, which is a build dependency but will only be used if check is also present. As the libxcb unit test suite is minimal at present, forcibly disable the test for check and remove the libxslt-native build dependency. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb.inc5
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb/disable-check.patch25
2 files changed, 28 insertions, 2 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb.inc b/meta/recipes-graphics/xorg-lib/libxcb.inc
index 75a43a5d3a..453f5500c3 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb.inc
+++ b/meta/recipes-graphics/xorg-lib/libxcb.inc
@@ -10,10 +10,11 @@ BBCLASSEXTEND = "native nativesdk"
SECTION = "x11/libs"
LICENSE = "MIT-X"
-DEPENDS = "xcb-proto xproto libxau libxslt-native xcb-proto-native libpthread-stubs"
+DEPENDS = "xcb-proto xproto libxau xcb-proto-native libpthread-stubs"
SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
- file://xcbincludedir.patch"
+ file://xcbincludedir.patch \
+ file://disable-check.patch"
PACKAGES_DYNAMIC = "^libxcb-.*"
diff --git a/meta/recipes-graphics/xorg-lib/libxcb/disable-check.patch b/meta/recipes-graphics/xorg-lib/libxcb/disable-check.patch
new file mode 100644
index 0000000000..5f59a2b9b8
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb/disable-check.patch
@@ -0,0 +1,25 @@
+The "check" package is checked for without an explicit enable/disable option,
+which can lead to non-deterministic build issues with both check and libxslt.
+
+As the unit test suite is minimal at present, simply disable the test suite. In
+the future if the test suite is expanded this can be made conditional on the
+ptest DISTRO_FEATURE.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+
+diff --git a/configure.ac b/configure.ac
+index 6d7c9a5..22cceb9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,7 +21,8 @@ AC_USE_SYSTEM_EXTENSIONS
+
+ AM_PATH_PYTHON([2.6])
+
+-PKG_CHECK_MODULES(CHECK, [check >= 0.9.4], [HAVE_CHECK=yes], [HAVE_CHECK=no])
++dnl PKG_CHECK_MODULES(CHECK, [check >= 0.9.4], [HAVE_CHECK=yes], [HAVE_CHECK=no])
++HAVE_CHECK=no
+ AM_CONDITIONAL(HAVE_CHECK, test x$HAVE_CHECK = xyes)
+
+ AC_CONFIG_HEADERS([src/config.h]) \ No newline at end of file