aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-07-26 12:58:58 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 15:39:17 +0100
commit6e280bf3e2edf3a9e7dfe0e86bcc5c763d52211a (patch)
treed06e8ef2bfa72c0d4867574d754474c437d0ee1c
parentcd2975f7ad380aaac8c88bc151a2c34a42d4c540 (diff)
downloadopenembedded-core-contrib-6e280bf3e2edf3a9e7dfe0e86bcc5c763d52211a.tar.gz
apr: Fix multilib header conflict - apr.h
apr.h conflicts between 32-bit and 64-bit versions Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta/recipes-support/apr/apr_1.4.2.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.2.bb b/meta/recipes-support/apr/apr_1.4.2.bb
index 89bdadf955..b37001d4ca 100644
--- a/meta/recipes-support/apr/apr_1.4.2.bb
+++ b/meta/recipes-support/apr/apr_1.4.2.bb
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b \
file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
-PR = "r0"
+PR = "r1"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
file://configure_fixes.patch;patch=1 \
@@ -17,7 +17,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
SRC_URI[md5sum] = "4b00e8f70c067893d075577962656b35"
SRC_URI[sha256sum] = "2017ca700694d09d2b0b21dd7c4d195e43a48735aac88526160c6195ee8f5391"
-inherit autotools lib_package binconfig
+inherit autotools lib_package binconfig multilib_header
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
@@ -34,6 +34,10 @@ do_configure_append() {
sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/apr_rules.mk
}
+do_install_append() {
+ oe_multilib_header apr.h
+}
+
SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
apr_sysroot_preprocess () {