summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Rozhkov <dmitry.rozhkov@linux.intel.com>2016-05-31 11:35:05 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 08:36:25 +0100
commit25168b82f82f9b205973014664fe2044ec4d4d6d (patch)
treef6e944e5c85df7a3ff669f870c7e12f3bc0c9949
parentd904d24a9cb1f15688b9924981d9c3d4dac7065f (diff)
downloadopenembedded-core-contrib-25168b82f82f9b205973014664fe2044ec4d4d6d.tar.gz
pango_1.40.1.bb: Fix compilation error
On a build host not having libglib-2.0 installed compiling pango fails with the error message ./gen-all-unicode: error while loading shared libraries: libglib-2.0.so.0: cannot open shared object file: No such file or directory The executable doesn't have RPATH set to the library installed in the native sysroot. The fix sets RPATH. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/pango/pango_1.40.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.40.1.bb b/meta/recipes-graphics/pango/pango_1.40.1.bb
index 6e1e6c9be6..60288a19be 100644
--- a/meta/recipes-graphics/pango/pango_1.40.1.bb
+++ b/meta/recipes-graphics/pango/pango_1.40.1.bb
@@ -36,7 +36,7 @@ LIBV = "1.8.0"
# This binary needs to be compiled for the host architecture. This isn't pretty!
do_compile_prepend_class-target () {
if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
- make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
+ make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
fi
}