summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-01-23 12:54:32 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 10:20:04 +0000
commit29c71eeb98aa8ce0fb0e0a30483499525bf6305d (patch)
tree4c83cee5a2da1e7d8f9c2f560587512a699971f4
parentcc8d02c582a72d07fd08c59d14ee5720e01a5cd9 (diff)
downloadopenembedded-core-contrib-29c71eeb98aa8ce0fb0e0a30483499525bf6305d.tar.gz
linux-yocto/qemuppc: fix console and ethernet
Two issues are fixed with this commit, the ability to use the keyboard on a graphical qemu boot and enabling ethernet by default on a 3.0 kernel. The keyboard is fixed via the same method as the other simulations with the addition of console=tty on the qemu command line. Ethernet is fixed by adding a dependency of PCNET32 to the qemuppc configuration, which allows us to build ethernet directly into the image. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb2
-rwxr-xr-xscripts/runqemu-internal2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index 145e54802e..9a543ab8b9 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -16,7 +16,7 @@ LINUX_KERNEL_TYPE = "preempt-rt"
SRCREV_machine ?= "f1cc220f4ddf434bf254707c83a45794a63f117f"
SRCREV_machine_qemuppc ?= "8bd5b80cb3243dadc9d6c5c09482c49994dff1a8"
-SRCREV_meta ?= "73dafd44ea875df654129b32b2877f342d5573e4"
+SRCREV_meta ?= "665fea1c249b4f335cb1c9a46a9f2c138d611f1a"
PR = "r1"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index 0b79beec23..10859e7066 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemuppc ?= "53e71af30e30162e17e32b2f57e4481f5bc0573e"
SRCREV_machine_qemux86 ?= "9e73573b6b227ab2c62e66e63470866d136f8d76"
SRCREV_machine_qemux86-64 ?= "3551fd0412965b1f6b0b2f6ba35f7fecdaddb58a"
SRCREV_machine ?= "6f5b11830deba4a6262c8c4abf67e608924f649e"
-SRCREV_meta ?= "73dafd44ea875df654129b32b2877f342d5573e4"
+SRCREV_meta ?= "665fea1c249b4f335cb1c9a46a9f2c138d611f1a"
PR = "r2"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/scripts/runqemu-internal b/scripts/runqemu-internal
index 11dda5582e..21fbce3ee9 100755
--- a/scripts/runqemu-internal
+++ b/scripts/runqemu-internal
@@ -394,7 +394,7 @@ if [ "$MACHINE" = "qemuppc" ]; then
QEMU_UI_OPTIONS="$QEMU_UI_OPTIONS"
QEMU_NETWORK_CMD="-net nic,model=pcnet $QEMU_TAP_CMD"
if [ "$FSTYPE" = "ext3" -o "$FSTYPE" = "btrfs" ]; then
- KERNCMDLINE="root=/dev/hda rw console=ttyS0 $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
+ KERNCMDLINE="root=/dev/hda rw console=ttyS0 console=tty $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
QEMUOPTIONS="$QEMU_NETWORK_CMD -cpu $CPU_SUBTYPE -M $MACHINE_SUBTYPE -hda $ROOTFS -no-reboot $QEMU_UI_OPTIONS"
fi
if [ "$FSTYPE" = "nfs" ]; then