summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-14 11:25:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:48:04 +0000
commit3c1e7e50c929436d0007d60e738c8270e7e6c7d9 (patch)
tree30bc1edc4d5718b4c49c7a22c6e91e47d25eb16a
parent1ebf3774655a57807ca5e03530fef2bd80442adb (diff)
downloadopenembedded-core-contrib-3c1e7e50c929436d0007d60e738c8270e7e6c7d9.tar.gz
python3-cryptography-vectors: Fix reproducibility
We regenerate the pycache files and the checksums in the manifest are incorrect. Remove them to avoid this and ensure reproducibility. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
index b9e6b811c3..da6718fb90 100644
--- a/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
${PYTHON_PN}-cryptography \
"
+do_install:append () {
+ # Remove the sha256 checksum lines for pycache files
+ sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
+}
+
BBCLASSEXTEND = "native nativesdk"
UPSTREAM_CHECK_REGEX = ""