summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-01 16:20:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-01 18:19:09 +0000
commit966b245a3a4fda1dc1333194e88fdbac34331b6a (patch)
treedfc98df1e8268ea69ab7abd6dfa85b77eca4e9da
parentc869560c25223dd336ce84847ddbdbe44e4c391c (diff)
downloadopenembedded-core-contrib-966b245a3a4fda1dc1333194e88fdbac34331b6a.tar.gz
perl: add dependencies for optional modules
Particularly the LSB test suite was failing due to missing crypt() support. [YOCTO #13160] Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index dc6689738d..71653feb53 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -32,6 +32,8 @@ S = "${WORKDIR}/perl-${PV}"
inherit upstream-version-is-even
+DEPENDS += "db gdbm zlib virtual/crypt"
+
do_unpack_append() {
bb.build.exec_func('do_copy_perlcross', d)
}