summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-01-05 18:18:55 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-06 10:06:32 +0000
commitd2d5456cd3b3bd3e52a5dedccca4d46e3a7986d1 (patch)
tree2931470b69821305d33f8c8b4b52f6dea9329fc4
parentb91c0f435bb7af58ccf31678ffebc890908d37cd (diff)
downloadopenembedded-core-contrib-d2d5456cd3b3bd3e52a5dedccca4d46e3a7986d1.tar.gz
insane.bbclass: Fix message for LIC_FILES_CHKSUM Errors
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/classes/insane.bbclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 225530a2c9..71ed5b6433 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -349,7 +349,7 @@ def package_qa_check_license(workdir, d):
# just throw a warning now. Once licensing data in entered for enough of the recipes,
# this will be converted into error and False will be returned.
bb.error(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
- return True
+ return False
srcdir = bb.data.getVar('S', d, True)
@@ -357,10 +357,10 @@ def package_qa_check_license(workdir, d):
(type, host, path, user, pswd, parm) = bb.decodeurl(url)
srclicfile = os.path.join(srcdir, path)
if not os.path.isfile(srclicfile):
- raise bb.build.FuncFailed( "LIC_FILES_CHKSUM points to invalid file: " + path)
+ raise bb.build.FuncFailed( pn + ": LIC_FILES_CHKSUM points to invalid file: " + path)
if 'md5' not in parm:
- bb.error("md5 checksum is not specified for ", url)
+ bb.error(pn + ": md5 checksum is not specified for ", url)
return False
beginline, endline = 0, 0
if 'beginline' in parm:
@@ -391,11 +391,11 @@ def package_qa_check_license(workdir, d):
os.unlink(tmplicfile)
if parm['md5'] == md5chksum:
- bb.note ("md5 checksum matched for ", url)
+ bb.note (pn + ": md5 checksum matched for ", url)
else:
- bb.error ("md5 data is not matching for ", url)
- bb.error ("The new md5 checksum is ", md5chksum)
- bb.error ("Check if the license information has changed, and if it has update the .bb file with correct license")
+ bb.error (pn + ": md5 data is not matching for ", url)
+ bb.error (pn + ": The new md5 checksum is ", md5chksum)
+ bb.error (pn + ": Check if the license information has changed in")
sane = False
return sane
@@ -605,5 +605,5 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
Missing inherit gettext?""" % config)
if not package_qa_check_license(workdir, d):
- bb.error("Licensing warning: LIC_FILES_CHKSUM does not match, please fix")
+ bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix")
}