summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFahad Arslan <Fahad_Arslan@mentor.com>2014-01-20 15:38:20 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:48:24 +0000
commite8f707f16a38d85535593a32efff6dcbf4ddb203 (patch)
treed2f6d653c57c1d5ccf8ca5d3f9a1fde005334c2a
parent262e69c9c7acf0beb7bb6b96299e3c993c906434 (diff)
downloadopenembedded-core-contrib-e8f707f16a38d85535593a32efff6dcbf4ddb203.tar.gz
speex: configure in float or fixed mode based on TARGET_FPU
Decide float or fixed mode usage depending on whether hardware FPU is present or not. Signed-off-by: Fahad Arslan <Fahad_Arslan@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-multimedia/speex/speex-fpu.inc4
-rw-r--r--meta/recipes-multimedia/speex/speex_1.2rc1.bb4
2 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/speex/speex-fpu.inc b/meta/recipes-multimedia/speex/speex-fpu.inc
new file mode 100644
index 0000000000..2571d32484
--- /dev/null
+++ b/meta/recipes-multimedia/speex/speex-fpu.inc
@@ -0,0 +1,4 @@
+def get_speex_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixed-point --disable-float-api --disable-vbr"
+ return ""
diff --git a/meta/recipes-multimedia/speex/speex_1.2rc1.bb b/meta/recipes-multimedia/speex/speex_1.2rc1.bb
index 5de0169354..9fd88a39f3 100644
--- a/meta/recipes-multimedia/speex/speex_1.2rc1.bb
+++ b/meta/recipes-multimedia/speex/speex_1.2rc1.bb
@@ -19,5 +19,7 @@ PARALLEL_MAKE = ""
inherit autotools pkgconfig lib_package
EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} \
- --disable-float-api --disable-vbr \
--with-ogg-includes=${STAGING_INCDIR} --disable-oggtest"
+
+require speex-fpu.inc
+EXTRA_OECONF += "${@get_speex_fpu_setting(bb, d)}"