summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2019-02-21 22:13:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 10:42:56 +0000
commitf78e2fc921093cdd279f4245760b5e0a7adbe85c (patch)
tree161fcdc9225124e22778935fe700a9f941797849
parentddf5421331180bc45697511b44cdd4a4e6dda6ff (diff)
downloadopenembedded-core-contrib-f78e2fc921093cdd279f4245760b5e0a7adbe85c.tar.gz
alsa-utils: 1.1.6 -> 1.1.8
Changelogs: http://alsa-project.org/main/index.php/Changes_v1.1.6_v1.1.7 http://alsa-project.org/main/index.php/Changes_v1.1.7_v1.1.8 There's a new program, axfer, which is a reimplementation of aplay (and arecord). The purpose of the rewrite is to have code that is easier to maintain. For now both implementations exist, and I decided to put both in the aplay package. The new 89-alsa-ucm.rules udev file initializes the mixer settings for certain hardware. It's needed for making the hardware usable at boot, in case there's no higher level software (such as PulseAudio) managing the mixer settings. Shipping hardware specific configuration in alsa-utils seems wrong, but I don't know what else to do. I added it to the alsaucm package, because it's kind of tied to the alsaucm utility (the udev rules execute the alsaucm program, and the build system installs the rules file only when alsaucm is enabled). Ideally the UCM configuration in alsa-lib would define the default UCM verb for each hardware, then the udev rules file could just enable the default verb, and there would be no hardware specific configuration in alsa-utils. But that requires upstream development effort. SRC_URI was changed to a more reliable source (at least currently the ftp server is flaky). Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.8.bb (renamed from meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.6.bb)0
-rw-r--r--meta/recipes-multimedia/alsa/alsa-utils_1.1.8.bb (renamed from meta/recipes-multimedia/alsa/alsa-utils_1.1.6.bb)15
2 files changed, 7 insertions, 8 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.8.bb
index fef79d9c9c..fef79d9c9c 100644
--- a/meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.6.bb
+++ b/meta/recipes-multimedia/alsa/alsa-utils-scripts_1.1.8.bb
diff --git a/meta/recipes-multimedia/alsa/alsa-utils_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-utils_1.1.8.bb
index b8ba0cb22a..96d54e593a 100644
--- a/meta/recipes-multimedia/alsa/alsa-utils_1.1.6.bb
+++ b/meta/recipes-multimedia/alsa/alsa-utils_1.1.8.bb
@@ -19,11 +19,10 @@ PACKAGECONFIG[bat] = "--enable-bat,--disable-bat,fftwf"
PACKAGECONFIG[udev] = "--with-udev-rules-dir=`pkg-config --variable=udevdir udev`/rules.d,--with-udev-rules-dir=/unwanted/rules.d,udev"
PACKAGECONFIG[manpages] = "--enable-xmlto, --disable-xmlto, xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
-SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
- "
-
-SRC_URI[md5sum] = "50ae75567459646b843bed78d916b002"
-SRC_URI[sha256sum] = "155caecc40b2220f686f34ba3655a53e3bdbc0586adb1056733949feaaf7d36e"
+# alsa-utils specified in SRC_URI due to alsa-utils-scripts recipe
+SRC_URI = "https://www.alsa-project.org/files/pub/utils/alsa-utils-${PV}.tar.bz2"
+SRC_URI[md5sum] = "54d6f9b483144823d0fc0c26e8cea028"
+SRC_URI[sha256sum] = "fd9bf528922b3829a91913b89a1858c58a0b24271a7b5f529923aa9ea12fa4cf"
# On build machines with python-docutils (not python3-docutils !!) installed
# rst2man (not rst2man.py) is detected and compile fails with
@@ -59,7 +58,7 @@ RDEPENDS_${PN} += "${ALSA_UTILS_PKGS}"
FILES_${PN} = ""
FILES_alsa-utils-alsabat = "${bindir}/alsabat"
FILES_alsa-utils-alsatplg = "${bindir}/alsatplg"
-FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord"
+FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord ${bindir}/axfer"
FILES_alsa-utils-amixer = "${bindir}/amixer"
FILES_alsa-utils-alsamixer = "${bindir}/alsamixer"
FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/speaker-test/"
@@ -67,10 +66,10 @@ FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bind
FILES_alsa-utils-aconnect = "${bindir}/aconnect"
FILES_alsa-utils-aseqnet = "${bindir}/aseqnet"
FILES_alsa-utils-iecset = "${bindir}/iecset"
-FILES_alsa-utils-alsactl = "${sbindir}/alsactl */udev/rules.d */*/udev/rules.d ${systemd_unitdir} ${localstatedir}/lib/alsa ${datadir}/alsa/init/"
+FILES_alsa-utils-alsactl = "${sbindir}/alsactl */udev/rules.d/90-alsa-restore.rules */*/udev/rules.d/90-alsa-restore.rules ${systemd_unitdir} ${localstatedir}/lib/alsa ${datadir}/alsa/init/"
FILES_alsa-utils-aseqdump = "${bindir}/aseqdump"
FILES_alsa-utils-alsaloop = "${bindir}/alsaloop"
-FILES_alsa-utils-alsaucm = "${bindir}/alsaucm"
+FILES_alsa-utils-alsaucm = "${bindir}/alsaucm */udev/rules.d/89-alsa-ucm.rules */*/udev/rules.d/89-alsa-ucm.rules"
SUMMARY_alsa-utils-alsabat = "Command-line sound tester for ALSA sound card driver"
SUMMARY_alsa-utils-alsatplg = "Converts topology text files into binary format for kernel"