aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/ref-manual/ref-variables.xml
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-05-05 07:39:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-28 18:02:28 +0100
commite05c636bc85fd06b8f5b2f941ddd7d5b8e3e8b9c (patch)
tree522be06d281f206191f33fd4a8895d20138efabb /documentation/ref-manual/ref-variables.xml
parent8c9fb712268ee1bc6cbdb3f0415be01ede3af152 (diff)
downloadopenembedded-core-contrib-e05c636bc85fd06b8f5b2f941ddd7d5b8e3e8b9c.tar.gz
ref-manual, dev-manual: Added info about make race work-around
I updated both the PARALLEL_MAKE and PARALLEL_MAKEINST variables by expanding the note to indicate how to prohibit parallel make threads. Also, added a cross-referencing link to the "Debugging Parallel Make Races" section. I added a short note to the start of the "Debugging Parallel Make Races" section noting that if they can't properly fix the condition, they can always do a work-around to set the PARALLEL_MAKE or PARALLEL_MAKEINST variables to null. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: f8dccf3f115647cb039d91415819186cf38fa8bb) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/ref-manual/ref-variables.xml')
-rw-r--r--documentation/ref-manual/ref-variables.xml31
1 files changed, 21 insertions, 10 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 27008c7a5d..dfe775b23f 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -8525,13 +8525,18 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</para>
<para>
- The OpenEmbedded build system automatically sets this
- variable to be equal to the number of cores the build
- system uses.
+ By default, the OpenEmbedded build system automatically
+ sets this variable to be equal to the number of cores the
+ build system uses.
<note>
- Individual recipes might clear out this variable if
- the software being built has problems running its
- <filename>make</filename> process in parallel.
+ If the software being built experiences dependency
+ issues during the <filename>do_compile</filename>
+ task that result in race conditions, you can clear
+ the <filename>PARALLEL_MAKE</filename> variable within
+ the recipe as a workaround.
+ For information on addressing race conditions, see the
+ "<ulink url='&YOCTO_DOCS_DEV_URL;#debugging-parallel-make-races'>Debugging Parallel Make Races</ulink>"
+ section in the Yocto Project Development Manual.
</note>
For single socket systems (i.e. one CPU), you should not
have to override this variable to gain optimal parallelism
@@ -8539,7 +8544,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
However, if you have very large systems that employ
multiple physical CPUs, you might want to make sure the
<filename>PARALLEL_MAKE</filename> variable is not
- set higher than "20".
+ set higher than "-j 20".
</para>
<para>
@@ -8564,9 +8569,15 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
This variable defaults to the value of
<link linkend='var-PARALLEL_MAKE'><filename>PARALLEL_MAKE</filename></link>.
<note>
- Individual recipes might clear out this variable if
- the software being built has problems running its
- <filename>make install</filename> process in parallel.
+ If the software being built experiences dependency
+ issues during the
+ <filename>do_install</filename> task that result in
+ race conditions, you can clear the
+ <filename>PARALLEL_MAKEINST</filename> variable within
+ the recipe as a workaround.
+ For information on addressing race conditions, see the
+ "<ulink url='&YOCTO_DOCS_DEV_URL;#debugging-parallel-make-races'>Debugging Parallel Make Races</ulink>"
+ section in the Yocto Project Development Manual.
</note>
</para>
</glossdef>