aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-05-04 15:29:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-28 18:02:28 +0100
commit113c4279e7b9082837ad70559dc70601c5ca33ed (patch)
treecdf08e9e8da0e26d5bcf35593bfcaa1a7270f9e5 /documentation
parent2a95850d641445e8b792c566f35209698ef1dd68 (diff)
downloadopenembedded-core-contrib-113c4279e7b9082837ad70559dc70601c5ca33ed.tar.gz
ref-manual: Added descriptions for four new variables
Fixes [YOCTO #7665] Added descriptions in the glossary for the following variables: * SDK_HOST_MANIFEST * SDK_TARGET_MANIFEST * SDK_VERSION * TOOLCHAIN_OUTPUTNAME (From yocto-docs rev: d8a7e3443d33d02d88e9d603dcff917a5508ae17) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/ref-manual/ref-variables.xml118
1 files changed, 118 insertions, 0 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 71bd8e5260..c330fe04a1 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -10020,6 +10020,39 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</glossdef>
</glossentry>
+ <glossentry id='var-SDK_HOST_MANIFEST'><glossterm>SDK_HOST_MANIFEST</glossterm>
+ <info>
+ SDK_HOST_MANIFEST[doc] = "The manifest file for the host part of the SDK. This file lists all the installed packages that make up the host part of the SDK."
+ </info>
+ <glossdef>
+ <para role="glossdeffirst">
+<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
+ The manifest file for the host part of the SDK.
+ This file lists all the installed packages that make up
+ the host part of SDK.
+ The file contains package information on a line-per-package
+ basis as follows:
+ <literallayout class='monospaced'>
+ <replaceable>packagename</replaceable> <replaceable>packagearch</replaceable> <replaceable>version</replaceable>
+ </literallayout>
+ </para>
+
+ <para>
+ The
+ <link linkend='ref-classes-populate-sdk-*'><filename>populate_sdk_base</filename></link>
+ class defines the manifest file as follows:
+ <literallayout class='monospaced'>
+ SDK_HOST_MANIFEST = "${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.host.manifest"
+ </literallayout>
+ The location is derived using the
+ <link linkend='var-SDK_DEPLOY'><filename>SDK_DEPLOY</filename></link>
+ and
+ <link linkend='var-TOOLCHAIN_OUTPUTNAME'><filename>TOOLCHAIN_OUTPUTNAME</filename></link>
+ variables.
+ </para>
+ </glossdef>
+ </glossentry>
+
<glossentry id='var-SDK_NAME'><glossterm>SDK_NAME</glossterm>
<info>
SDK_NAME[doc] = "The base name for SDK output files."
@@ -10146,6 +10179,39 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</glossdef>
</glossentry>
+ <glossentry id='var-SDK_TARGET_MANIFEST'><glossterm>SDK_TARGET_MANIFEST</glossterm>
+ <info>
+ SDK_TARGET_MANIFEST[doc] = "The manifest file for the target part of the SDK. This file lists all the installed packages that make up the target part of the SDK."
+ </info>
+ <glossdef>
+ <para role="glossdeffirst">
+<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
+ The manifest file for the target part of the SDK.
+ This file lists all the installed packages that make up
+ the target part of the SDK.
+ The file contains package information on a line-per-package
+ basis as follows:
+ <literallayout class='monospaced'>
+ <replaceable>packagename</replaceable> <replaceable>packagearch</replaceable> <replaceable>version</replaceable>
+ </literallayout>
+ </para>
+
+ <para>
+ The
+ <link linkend='ref-classes-populate-sdk-*'><filename>populate_sdk_base</filename></link>
+ class defines the manifest file as follows:
+ <literallayout class='monospaced'>
+ SDK_TARGET_MANIFEST = "${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.target.manifest"
+ </literallayout>
+ The location is derived using the
+ <link linkend='var-SDK_DEPLOY'><filename>SDK_DEPLOY</filename></link>
+ and
+ <link linkend='var-TOOLCHAIN_OUTPUTNAME'><filename>TOOLCHAIN_OUTPUTNAME</filename></link>
+ variables.
+ </para>
+ </glossdef>
+ </glossentry>
+
<glossentry id='var-SDK_VENDOR'><glossterm>SDK_VENDOR</glossterm>
<info>
SDK_VENDOR[doc] = "Specifies the name of the SDK vendor."
@@ -10158,6 +10224,32 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</glossdef>
</glossentry>
+ <glossentry id='var-SDK_VERSION'><glossterm>SDK_VERSION</glossterm>
+ <info>
+ SDK_VERSION[doc] = "Specifies the version for the SDK."
+ </info>
+ <glossdef>
+ <para role="glossdeffirst">
+<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
+ Specifies the version of the SDK.
+ The distribution configuration file (e.g.
+ <filename>/meta-yocto/conf/distro/poky.conf</filename>)
+ defines the <filename>SDK_VERSION</filename> as follows:
+ <literallayout class='monospaced'>
+ SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
+ </literallayout>
+ </para>
+
+ <para>
+ For additional information, see the
+ <link linkend='var-DISTRO_VERSION'><filename>DISTRO_VERSION</filename></link>
+ and
+ <link linkend='var-DATE'><filename>DATE</filename></link>
+ variables.
+ </para>
+ </glossdef>
+ </glossentry>
+
<glossentry id='var-SDKIMAGE_FEATURES'><glossterm>SDKIMAGE_FEATURES</glossterm>
<info>
SDKIMAGE_FEATURES[doc] = "Equivalent to IMAGE_FEATURES. However, this variable applies to the SDK generated from an image using the command 'bitbake -c populate_sdk imagename'."
@@ -12550,6 +12642,32 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</glossdef>
</glossentry>
+ <glossentry id='var-TOOLCHAIN_OUTPUTNAME'><glossterm>TOOLCHAIN_OUTPUTNAME</glossterm>
+ <info>
+ TOOLCHAIN_OUTPUTNAME[doc] = "Defines the name used for the toolchain output."
+ </info>
+ <glossdef>
+ <para role="glossdeffirst">
+<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
+ This variable defines the name used for the toolchain
+ output.
+ The
+ <link linkend='ref-classes-populate-sdk-*'><filename>populate_sdk_base</filename></link>
+ class sets the
+ <filename>TOOLCHAIN_OUTPUTNAME</filename> variable as
+ follows:
+ <literallayout class='monospaced'>
+ TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-toolchain-${SDK_VERSION}"
+ </literallayout>
+ See the
+ <link linkend='var-SDK_NAME'><filename>SDK_NAME</filename></link>
+ and
+ <link linkend='var-SDK_VERSION'><filename>SDK_VERSION</filename></link>
+ variables for additional information.
+ </para>
+ </glossdef>
+ </glossentry>
+
<glossentry id='var-TOOLCHAIN_TARGET_TASK'><glossterm>TOOLCHAIN_TARGET_TASK</glossterm>
<info>
TOOLCHAIN_TARGET_TASK[doc] = "This variable lists packages the OpenEmbedded build system uses when it creates the target part of an SDK, which includes libraries and headers."