summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-10 17:28:40 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-10 17:28:40 +0100
commite4a43a1e2eb7b02f68555cfd5508f4a2ca1ec702 (patch)
tree81a113a9fc1691840a542186c91cd28c1eb404fd /meta-gnome
parent4378f77b0757aae29b22b367dbd468bc56a252e2 (diff)
downloadopenembedded-core-contrib-e4a43a1e2eb7b02f68555cfd5508f4a2ca1ec702.tar.gz
Add gnome-settings-daemon and libgnomekbd from OE but with fixed dependencies
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/packages/gnome/gnome-settings-daemon_2.26.1.bb22
-rw-r--r--meta-gnome/packages/gnome/libgnomekbd_2.26.0.bb19
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-gnome/packages/gnome/gnome-settings-daemon_2.26.1.bb b/meta-gnome/packages/gnome/gnome-settings-daemon_2.26.1.bb
new file mode 100644
index 0000000000..4fd2a35778
--- /dev/null
+++ b/meta-gnome/packages/gnome/gnome-settings-daemon_2.26.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME settings daemon"
+LICENSE = "GPL"
+
+PR = "r1"
+
+DEPENDS = "libxklavier libgnomekbd gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl gnome-desktop"
+
+inherit gnome
+
+FILES_${PN} += "${libdir}/gnome-settings-daemon-2.0/*.so ${libdir}/gnome-settings-daemon-2.0/*plugin \
+ ${datadir}/dbus-1/ \
+ ${datadir}/icon* \
+ ${datadir}/xsession*"
+
+FILES_${PN}-dbg += "${libdir}/gnome-settings-daemon-2.0/.debug"
+FILES_${PN}-dev += "${libdir}/gnome-settings-daemon-2.0/*.a ${libdir}/gnome-settings-daemon-2.0/*.la"
+
+do_stage() {
+ autotools_stage_all
+}
+
+ASNEEDED = "" \ No newline at end of file
diff --git a/meta-gnome/packages/gnome/libgnomekbd_2.26.0.bb b/meta-gnome/packages/gnome/libgnomekbd_2.26.0.bb
new file mode 100644
index 0000000000..a5e95759ad
--- /dev/null
+++ b/meta-gnome/packages/gnome/libgnomekbd_2.26.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "GNOME keyboard library"
+LICENSE = "LGPL"
+
+DEPENDS = "gconf-dbus dbus libxklavier gtk+"
+
+inherit gnome
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+