summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-02-17 18:14:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-21 21:52:08 +0000
commit50ccfaa8b3ed340ee7f906934b211a1c73eb8db5 (patch)
tree8fa04acfbd18804f9518974e8e6a6d68511b8244 /meta-selftest
parent2702bac9e5c13f8a30153a1c45b278eebc9f11e5 (diff)
downloadopenembedded-core-contrib-50ccfaa8b3ed340ee7f906934b211a1c73eb8db5.tar.gz
oeqa/selftest/bblogging: Add logging tests for bb.build.exec_func with shell/python code
The situation regarding logging is different when a function called by bb.build.exec_func() fails compared to when the task code fails directly. There is a recent fix in bitbake to solve that and these tests will hopefully prevent regressions. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/logging-test/logging-test.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/logging-test/logging-test.bb b/meta-selftest/recipes-test/logging-test/logging-test.bb
index a6100123f9..ac3fb46f45 100644
--- a/meta-selftest/recipes-test/logging-test/logging-test.bb
+++ b/meta-selftest/recipes-test/logging-test/logging-test.bb
@@ -11,12 +11,22 @@ do_shelltest() {
}
addtask do_shelltest
+python do_pythontest_exec_func_shell() {
+ bb.build.exec_func('do_shelltest', d)
+}
+addtask do_pythontest_exec_func_shell
+
python do_pythontest_exit () {
print("This is python stdout")
sys.exit(1)
}
addtask do_pythontest_exit
+python do_pythontest_exec_func_python() {
+ bb.build.exec_func('do_pythontest_exit', d)
+}
+addtask do_pythontest_exec_func_python
+
python do_pythontest_fatal () {
print("This is python fatal test stdout")
bb.fatal("This is a fatal error")