aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-08-17 08:53:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-19 18:05:56 +0100
commit6b8bb442880ef18097e47761f4f3b6f555f2877c (patch)
tree0cff5a0a940471a2e8e5b8f7b05e3d24a6779c99 /meta-yocto-bsp
parent6f176d4c7b4f789c0551fc4caa01beb2eb100364 (diff)
downloadopenembedded-core-contrib-6b8bb442880ef18097e47761f4f3b6f555f2877c.tar.gz
genericx86*: Update BSPs to use 4.1 Kernel
This adds the initial bbappend to meta-yocto-bsp for the 4.1 kernel It also sets up the PREFERRED_VERSION for the X86 and X86-64 Generic BSPs to the 4.1 kernel. This has been tested on MinnowBoard (32bit) MinnowBoard Max (64bit) along with both 32 and 64 bit versions of the NUC. (From meta-yocto rev: e1fe9bc5211ad8fae3de6b1e3febba8364a5a943) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/include/genericx86-common.inc2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.1.bbappend11
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
index 840cc1027a..7c10b56c42 100644
--- a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
+++ b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
@@ -2,7 +2,7 @@ include conf/machine/include/x86-base.inc
MACHINE_FEATURES += "wifi efi pcbios"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_linux-yocto ?= "3.19%"
+PREFERRED_VERSION_linux-yocto ?= "4.1%"
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
XSERVER ?= "${XSERVER_X86_BASE} \
${XSERVER_X86_EXT} \
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.1.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.1.bbappend
new file mode 100644
index 0000000000..a5fe0e6984
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -0,0 +1,11 @@
+KBRANCH_genericx86 = "standard/base"
+KBRANCH_genericx86-64 = "standard/base"
+
+KMACHINE_genericx86 ?= "common-pc"
+KMACHINE_genericx86-64 ?= "common-pc-64"
+
+SRCREV_machine_genericx86 ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
+SRCREV_machine_genericx86-64 ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
+
+COMPATIBLE_MACHINE_genericx86 = "genericx86"
+COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"