aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-03 15:49:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-05 15:24:04 +0000
commit07db5222a970e40bff51c5df793f0021b0e2aba8 (patch)
treee75500ec080f157c861bcbc16b4c08cc3575a9b2 /meta/classes/autotools.bbclass
parent79ea036de331bde65a88fb777647dc099ef05acf (diff)
downloadopenembedded-core-contrib-07db5222a970e40bff51c5df793f0021b0e2aba8.tar.gz
alsa-tools/autotools: Ensure that aclocal files can be present with AUTOTOOLS_COPYACLOCAL variable
Introduce a AUTOTOOLS_COPYACLOCAL variable which forces the copy of the aclocal files even when a configure.ac/.in file isn't present. Use this new feature in alsa-tools. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 01e49c98bf..b645996136 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -138,7 +138,8 @@ ACLOCALDIR = "${B}/aclocal-copy"
python autotools_copy_aclocals () {
s = d.getVar("S", True)
if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"):
- return
+ if not d.getVar("AUTOTOOLS_COPYACLOCAL"):
+ return
taskdepdata = d.getVar("BB_TASKDEPDATA", False)
pn = d.getVar("PN", True)