summaryrefslogtreecommitdiffstats
path: root/meta/classes/cpan-base.bbclass
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-12-04 18:32:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 12:32:11 +0000
commitf31f6a70ec24e8c9515d69c5092e15effc5e7d4d (patch)
treef71de9f22d168e34caaa870970b7169a68fc080f /meta/classes/cpan-base.bbclass
parente220c8e308caac6ef1da038697927425a807d2f2 (diff)
downloadopenembedded-core-contrib-f31f6a70ec24e8c9515d69c5092e15effc5e7d4d.tar.gz
cpan-base: Add vardepvalue to get_perl_version function
* without this bitbake -S perf shows following error: ERROR: Bitbake's cached basehash does not match the one we just generated (/OE/oe-core/meta/recipes-kernel/perf/perf.bb.do_package)! if you run it twice, once without perl in sysroot and once with perl already built Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/cpan-base.bbclass')
-rw-r--r--meta/classes/cpan-base.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/cpan-base.bbclass b/meta/classes/cpan-base.bbclass
index 7e1e8d0d6b..aa502d5faa 100644
--- a/meta/classes/cpan-base.bbclass
+++ b/meta/classes/cpan-base.bbclass
@@ -10,6 +10,9 @@ RDEPENDS_${PN} += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
PERL_OWN_DIR = "${@["", "/perl-native"][(bb.data.inherits_class('native', d))]}"
# Determine the staged version of perl from the perl configuration file
+# Assign vardepvalue, because otherwise signature is changed before and after
+# perl is built (from None to real version in config.sh).
+get_perl_version[vardepvalue] = "${PERL_OWN_DIR}"
def get_perl_version(d):
import re
cfg = d.expand('${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/config.sh')