summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-09-24 12:00:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-25 09:35:55 +0100
commitb744f4cc2912334b8493a89525fd02af8e9b8edf (patch)
tree9cbacbc93cabaff5298e48095f66cda5ff9440f4 /meta/classes/libc-common.bbclass
parent9327ca868667b15f29af3123611d6f56b4249a63 (diff)
downloadopenembedded-core-contrib-b744f4cc2912334b8493a89525fd02af8e9b8edf.tar.gz
Add and use 'localedir' variable
This avoids the hardcoding of ${libdir}/locale which is all over the place, and will facilitate use of ${exec_prefix}/lib/locale instead of ${libdir}/locale. This doesn't actually change any output at this time. Verified this with buildhistory against the packages produced from core-image-base. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
index 06d520164e..0f499366db 100644
--- a/meta/classes/libc-common.bbclass
+++ b/meta/classes/libc-common.bbclass
@@ -5,7 +5,7 @@ do_install() {
install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
done
install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
- install -d ${D}${libdir}/locale
+ install -d ${D}${localedir}
make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
# get rid of some broken files...
for i in ${GLIBC_BROKEN_LOCALES}; do