summaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorJian Liu <jian.liu@windriver.com>2015-11-13 16:21:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-24 15:49:13 +0000
commit5c84057de5b31c5d6d9abfcca3078bf766a21d88 (patch)
tree7ddcc95e08b69f639b1ba660fda5ff588998a8f9 /meta/classes
parentd643e43622eb3e43fbb2e21fa33580e2fcdf42be (diff)
downloadopenembedded-core-contrib-5c84057de5b31c5d6d9abfcca3078bf766a21d88.tar.gz
archiver.bbclass: add bbappend when do_ar_recipe kernel and gcc packages
bbappend files are not included in the archiver during do_ar_recipe. Find and put them into the tarball. Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/archiver.bbclass10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/classes/archiver.bbclass b/meta/classes/archiver.bbclass
index d7a159dcd1..328e2ed11a 100644
--- a/meta/classes/archiver.bbclass
+++ b/meta/classes/archiver.bbclass
@@ -298,6 +298,16 @@ python do_ar_recipe () {
bb.utils.mkdirhier(outdir)
shutil.copy(bbfile, outdir)
+ pn = d.getVar('PN', True)
+ bbappend_files = d.getVar('BBINCLUDED', True).split()
+ # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
+ # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
+ bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" %pn)
+ bbappend_re1 = re.compile( r".*/%s\.bbappend$" %pn)
+ for file in bbappend_files:
+ if bbappend_re.match(file) or bbappend_re1.match(file):
+ shutil.copy(file, outdir)
+
dirname = os.path.dirname(bbfile)
bbpath = '%s:%s' % (dirname, d.getVar('BBPATH', True))
f = open(bbfile, 'r')