aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-19 17:48:38 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-20 12:27:56 +0100
commitd0bc7a53b1e61283fb155b4dcb67bc2ab3b1d7f0 (patch)
tree5484a2e880d90a671a963e4db5bf9617eb9fd912 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
parent75bde3ee02262cb3c6b91279ca277e3e5324ee5e (diff)
downloadopenembedded-core-contrib-d0bc7a53b1e61283fb155b4dcb67bc2ab3b1d7f0.tar.gz
u-boot, u-boot-fw-utils, u-boot-fw-utils-cross: Use uboot-config class
The U-Boot configuration has been consolidates into a single class to avoid code duplication. This is now done by uboot-config class, so we now use it. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
index e711951405..be543431b3 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -17,14 +17,7 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
-python () {
- if not d.getVar("UBOOT_MACHINE", True):
- PN = d.getVar("PN", True)
- FILE = os.path.basename(d.getVar("FILE", True))
- bb.debug(1, "To build %s, see %s for instructions on \
- setting up your machine config" % (PN, FILE))
- raise bb.parse.SkipPackage("UBOOT_MACHINE is not set in the %s machine configuration." % d.getVar("MACHINE", True))
-}
+inherit uboot-config
do_compile () {
oe_runmake ${UBOOT_MACHINE}