aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-18 00:34:18 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-18 14:18:05 +0100
commitd9abcc0a2a691ca60cc1cb2f48f1748b0de73ac8 (patch)
tree10ea54f7b66049c5d615a61e986cf4a6cf39c74c /meta/recipes-bsp/u-boot
parent2e90f8846db0f3ed99a175befff9ec67fe12bc4e (diff)
downloadopenembedded-core-contrib-d9abcc0a2a691ca60cc1cb2f48f1748b0de73ac8.tar.gz
u-boot-fw-utils: Skip package if UBOOT_MACHINE is unset
The UBOOT_MACHINE variable needs to be set so the firmware utils can know about some configuration settings which are board dependent. This patch ensures the package is skipped in case UBOOT_MACHINE is unset thus avoid its build in 'bitbake world' builds for incompatible machines. Fixes [YOCTO: #5223] Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
index f97df71a7f..e711951405 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -17,6 +17,15 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+python () {
+ if not d.getVar("UBOOT_MACHINE", True):
+ PN = d.getVar("PN", True)
+ FILE = os.path.basename(d.getVar("FILE", True))
+ bb.debug(1, "To build %s, see %s for instructions on \
+ setting up your machine config" % (PN, FILE))
+ raise bb.parse.SkipPackage("UBOOT_MACHINE is not set in the %s machine configuration." % d.getVar("MACHINE", True))
+}
+
do_compile () {
oe_runmake ${UBOOT_MACHINE}
oe_runmake env