aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-22 15:11:08 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-24 15:51:36 +0100
commite1b1b6313b57d069ef77bc6e1e1ebbb8f6fdda4e (patch)
tree30deff084cc8b70ad2431c0fa25cd987fefa8662 /meta/recipes-bsp
parent0f4552cde971a0de247b865b25136b03be91dc39 (diff)
downloadopenembedded-core-contrib-e1b1b6313b57d069ef77bc6e1e1ebbb8f6fdda4e.tar.gz
u-boot-mkimage: add 2012.04 release
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb
new file mode 100644
index 0000000000..9d59ef3a65
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+
+# This is needs to be validated among supported BSP's before we can
+# make it default
+DEFAULT_PREFERENCE = "-1"
+
+# This revision corresponds to the tag "v2012.04"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "2790bf69dc12fb9aeb9836904e5f57c7f83d5552"
+
+PV = "v2012.04+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"