aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-02-10 13:56:00 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-14 08:40:59 +0000
commit34a4413ef7a873e8bfed4153173cc7050965510b (patch)
treeea24d7359fe1c57f4ddda08b8a0db6e97d19655a /meta/recipes-bsp
parent1993237a90fb12de37d9212f900e48ebe67e9f55 (diff)
downloadopenembedded-core-contrib-34a4413ef7a873e8bfed4153173cc7050965510b.tar.gz
u-boot: update to version 2015.01
(From OE-Core rev: 62052810dbf3ed19697078a48b617bfbdadf2a29) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch36
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb (renamed from meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb)21
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb34
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb32
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc4
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2015.01.bb (renamed from meta/recipes-bsp/u-boot/u-boot_2014.07.bb)6
6 files changed, 85 insertions, 48 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch b/meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch
new file mode 100644
index 0000000000..381b505d1e
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils/0001-tools-env-fix-build-error.patch
@@ -0,0 +1,36 @@
+From ee2d75513452aa6d5306fd380104adc8a2f6d8f2 Mon Sep 17 00:00:00 2001
+From: Masahiro Yamada <yamada.m@jp.panasonic.com>
+Date: Wed, 3 Dec 2014 10:22:50 +0900
+Subject: [PATCH] tools: env: fix build error
+
+Since CONFIG_SYS_ARCH, CONFIG_SYS_CPU, ... were moved to Kconfig,
+tools/env/fw_printenv fails to build if CONFIG_ENV_VARS_UBOOT_CONFIG
+is defined.
+(I do not think this is the right way to fix the problem, but
+for now I do not have enough time to take a close look.)
+
+Upstream-Status: Submitted [http://patchwork.ozlabs.org/patch/417192/]
+
+Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
+Reported-by: Denys Dmytriyenko <denys@ti.com>
+---
+ tools/env/fw_env.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tools/env/fw_env.c b/tools/env/fw_env.c
+index 1173eea..698fe51 100644
+--- a/tools/env/fw_env.c
++++ b/tools/env/fw_env.c
+@@ -8,6 +8,9 @@
+ * SPDX-License-Identifier: GPL-2.0+
+ */
+
++/* FIXME: Do not include this */
++#include <linux/kconfig.h>
++
+ #include <errno.h>
+ #include <env_flags.h>
+ #include <fcntl.h>
+--
+2.2.0
+
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
index 9a304c8c5d..2b0550cb37 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
@@ -1,21 +1,24 @@
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
SECTION = "bootloader"
DEPENDS = "mtd-utils"
-# This revision corresponds to the tag "v2014.07"
+# This revision corresponds to the tag "v2015.01"
# We use the revision in order to avoid having to fetch it from the
# repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
-PV = "v2014.07+git${SRCPV}"
+PV = "v2015.01+git${SRCPV}"
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
+ file://0001-tools-env-fix-build-error.patch"
S = "${WORKDIR}/git"
INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -33,14 +36,14 @@ do_install () {
}
do_install_class-cross () {
- install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
uboot_fw_utils_cross() {
- sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
+ sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
deleted file mode 100644
index eabf680ec6..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "U-Boot bootloader image creation tool"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-SECTION = "bootloader"
-
-# This revision corresponds to the tag "v2014.07"
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
-
-PV = "v2014.07+git${SRCPV}"
-
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
-
-do_compile () {
- # Make sure the recompile is OK
- rm -f ${B}/tools/.depend
-
- make HOSTCC="${BUILD_CC}" HOSTLD="${BUILD_LD}" HOSTLDFLAGS="${BUILD_LDFLAGS}" HOSTSTRIP=true dot-config=0 scripts_basic
- sed 's/^tools-only: scripts_basic /tools-only: /' -i Makefile
- oe_runmake tools-only
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
- ln -sf uboot-mkimage ${D}${bindir}/mkimage
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
new file mode 100644
index 0000000000..57989c785f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.01.bb
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2015.01"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
+
+PV = "v2015.01+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index b898d6a34d..6bdc86ae0c 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -4,7 +4,7 @@ SECTION = "bootloaders"
PROVIDES = "virtual/bootloader"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
@@ -14,7 +14,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit uboot-config deploy
-EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
# Allow setting an additional version string that will be picked up by the
# u-boot build system and appended to the u-boot version. If the .scmversion
diff --git a/meta/recipes-bsp/u-boot/u-boot_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot_2015.01.bb
index 44cc52eb6c..6feac3107d 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2014.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2015.01.bb
@@ -2,8 +2,8 @@ require u-boot.inc
DEPENDS += "dtc-native"
-# This revision corresponds to the tag "v2014.07"
+# This revision corresponds to the tag "v2015.01"
# We use the revision in order to avoid having to fetch it from the repo during parse
-SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
+SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
-PV = "v2014.07+git${SRCPV}"
+PV = "v2015.01+git${SRCPV}"